qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "lei.dai@airlink-software.com" <lei....@airlink-software.com>
Subject [Qpid C++ Broker] Why broker link state retains connecting when I setup Broker Federation in windows using qpid-route ?
Date Fri, 04 Nov 2016 10:54:11 GMT
Hello, everybody !

I'm new in qpid and want to setup Broker Federation in windows.
I downloaded and built Qpid C++ Broker in windows. I can send messages with qpid-send to a
broker and receive them with qpid-receive from the same broker, but failed when I use federation.
The appearance is that the route was created but link state was not Operational but always
Connecting, and I could not receive message from destination broker when I sent message to
source broker.

Maybe there is some trouble in my configurations or my using but I don't know.
Is there anyone has some ideas ?
Thanks in advance.

What I have done is:
1. Download and build Qpid C++ Broker and Qpid Proton.
    Version infos:
         Qpid C++ Broker  1.35.0 (configured using CMake with default parameters)
         Qpid Proton 0.14.0 (also tried 0.15.0 but got same result)
         Windows 7
         Visual Studio 2010 (Win32 used)

2. Create root CA certificate and sign a server certificate with it, and then import all of
them into windows as trusted.

3. Start 2 broker instances in one PC on different ports.
    instance A: tcp port 5672, ssl port 5671
    instance B: tcp port 5682, ssl port 5681
    both of them use the server certificate imported into windows.
    
    other parameters:
          protocol-defaults=amqp1.0,amqp0-10
          auth=no
    
    Up to here, I can use qpid-send and qpid-receive to transfer messages with either of them.

4. Use qpid-route to add a dynamic route like this:
    >qpid-route dynamic add 172.16.28.144:5682 172.16.28.144:5672 amq.topic
    >qpid-route route list 172.16.28.144:5682
    172.16.28.144:5682 172.16.28.144:5672 amq.topic <dynamic>
    
    It seems that the route was created successfully. But when I check the link state:
    >qpid-route link list 172.16.28.144:5682

Host            Port    Transport Durable  State             Last Error
=============================================================================
172.16.28.144   5672    tcp          N     Connecting

    The result is almost the same when I set transport to ssl.
    >qpid-route -t ssl dynamic add 172.16.28.144:5682 172.16.28.144:5672 amq.topic
    >qpid-route link list 172.16.28.144:5682

Host            Port    Transport Durable  State             Last Error
=============================================================================
172.16.28.144   5672    ssl          N     Connecting

    The state was always Connecting and didn't changed even after several minutes.
    And if I check the connections using netstat, I didn't find any connection with port 5672
or 5682.

5. I don't know if there is some trouble with the link list, but the fact is I cannot transfer
messages through the route.
    receiver client:
        >qpid-receive.exe -b 172.16.28.144:5682 -a amq.topic -f
    sender client:
        >qpid-send -b 172.16.28.144:5672 -a amq.topic --content-string aaa
    But no message was received.

6. When I check the logs from the brokers, I mentioned that, if I use tcp transport, some
system errors appeared:
    [in broker 172.16.28.144:5682]
    2016-11-04 17:05:13 [System] error Connection qpid.tcp:172.16.28.144:5672 No protocol
received after 10s, closing
    [in broker 172.16.28.144:5672]
    2016-11-04 17:05:13 [System] error Connection qpid.172.16.28.144:5672-172.16.28.144:54192
No protocol received after 10s, closing
    


Lei Dai

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message