qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robbie Gemmell <robbie.gemm...@gmail.com>
Subject Re: Qpid dispatch router issue
Date Wed, 03 Aug 2016 15:13:12 GMT
On 3 August 2016 at 15:52, Gordon Sim <gsim@redhat.com> wrote:
> On 03/08/16 15:13, Robbie Gemmell wrote:
>>
>> ActiveMQ 5.9.0 is rather old and its AMQP 1.0 support was fairly
>> recent at the time, its changed a lot since then. You'll want to try a
>> newer version. 5.13.4 is the current, with 5.14.0 currently under vote
>> for release.
>
>
> Yes, if I recall correctly 5.9 did not implement heartbeats which is why the
> router is terminating the connection.

Correct. I hadn't read the earlier message yet or I'd probably have
pointed that out too. It wasnt supported for a while after that, I
think 5.12.0 perhaps.

> You may be able to workaround that be
> setting the idleTimeoutSeconds for the connector to 0. However as Robbie
> says, it would be better to update the broker as there will be many other
> potential issues fixed by that.
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> For additional commands, e-mail: users-help@qpid.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message