qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robbie Gemmell <robbie.gemm...@gmail.com>
Subject Re: Qpid Messaging with Proton can't send message to topic on ActiveMQ
Date Wed, 08 Jun 2016 08:16:36 GMT
Try adding some single quotes to escape the value.

http://qpid.2158936.n2.nabble.com/Qpid-Messaging-API-and-topics-tp7598962.html

Robbie

On 8 June 2016 at 07:46, Emilien <EmilienKia@eaton.com> wrote:
> Hello,
>
> We are using Qpid C++ messaging with Proton to send messages on queues and
> topics to Qpid C++ broker and it works perfectly.
>
> We want to be able to also connect to ActiveMQ broker and send messages to
> it. Sending messages on queues works well. But We cant send messages to
> topics.
> AFAIK, ActiveMQ naming policy is to prefix them by queue:// or topic:// and
> if message is received with a destination without a such prefix, it is
> considered as a queue. When I try to set the destination to
> "topic://mytopic" explicitly, ActiveMQ consider this destination as a queue
> called "topic:".
>
> We really want to be able to send messages to Qpid broker or ActiveMQ
> without difference from the client point of view (just reconfiguration, no -
> or few - additional code, no use of other library if possible).
>
> Do I miss something ? Any tip ?
>
> Best regards
>
> Emilien
>
>
>
>
> --
> View this message in context: http://qpid.2158936.n2.nabble.com/Qpid-Messaging-with-Proton-can-t-send-message-to-topic-on-ActiveMQ-tp7645254.html
> Sent from the Apache Qpid users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> For additional commands, e-mail: users-help@qpid.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message