qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julien Charon <Julien.Cha...@avitech.aero>
Subject Java broker crashes after stopping vhost
Date Fri, 18 Mar 2016 06:59:10 GMT
  Hi,


I ran into a strange behaviour of the java broker I'd like to report.
I did the following:
- Change the flow control of a queue in the web management console. An info tells me that
I have to restart the vhost so that changes will have effect
- Stop the vhost (default) in the web management console
- A popup shows that something is wrong I have to fix. There's only a cancel button, the same
popup shows again immediately after clicking the button
- I see the following in the logs:
"
2016-03-18 06:41:06,748 ERROR [IO-/172.24.102.24:51029] (o.a.q.s.Main) - Uncaught exception,
shutting down.
java.lang.NullPointerException: null
                at org.apache.qpid.server.transport.NetworkConnectionScheduler.processConnection(NetworkConnectionScheduler.java:142)
~[qpid-broker-core-6.0.1.jar:6.0.1]
                at org.apache.qpid.server.transport.SelectorThread$ConnectionProcessor.processConnection(SelectorThread.java:505)
~[qpid-broker-core-6.0.1.jar:6.0.1]
                at org.apache.qpid.server.transport.SelectorThread$SelectionTask.performSelect(SelectorThread.java:338)
~[qpid-broker-core-6.0.1.jar:6.0.1]
                at org.apache.qpid.server.transport.SelectorThread$SelectionTask.run(SelectorThread.java:87)
~[qpid-broker-core-6.0.1.jar:6.0.1]
                at org.apache.qpid.server.transport.SelectorThread.run(SelectorThread.java:463)
~[qpid-broker-core-6.0.1.jar:6.0.1]
                at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) ~[na:1.8.0_51]
                at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) ~[na:1.8.0_51]
                at java.lang.Thread.run(Unknown Source) ~[na:1.8.0_51]
"
- Trying to stop the broker gives me: No Qpid Brokers found running for user: xxx
- When I try to start the broker again, I get the very same error log as quoted above, I have
no chance to start the broker
Now what can I do to solve that? I'll try to delete the work directory and see if it comes
up again.
If not, I'll have to re-install and configure the broker, but that would not be a reasonable
solution in a production environment...
Did I do something wrong or is that a bug?


Best regards,
Julien

Avitech GmbH
Engineering AxL
Tel.: +49 (0)7541/282-177
Fax: +49 (0)7541/282-199
e-mail: julien.charon@avitech.aero<mailto:julien.charon@avitech.aero>
________________________________________________
Avitech GmbH
Principal Office: Bahnhofplatz 1 | 88045 Friedrichshafen | Germany
Court Registration: Amtsgericht Ulm | HRB 728293
Geschäftsführer/Managing Director: Jon Joseba Goyarzu Caño
http://avitech.aero<http://avitech.aero/>

This message may contain confidential information and is intended only for the individual
named. If you are not the named addressee you should not disseminate, distribute or copy this
e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by
mistake and delete this e-mail from your system.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message