qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Stitcher <astitc...@redhat.com>
Subject Re: Unresolved symbols in qpidd from DEB package
Date Thu, 21 Jan 2016 17:19:44 GMT
On Thu, 2016-01-21 at 13:51 +0100, Pål Skjager Løberg wrote:
> I have been using the packages from
> https://launchpad.net/~mcpierce/+archive/ubuntu/qpid-testing and late
> ly
> https://launchpad.net/~qpid/+archive/ubuntu/released on the client si
> de for
> a while. Now I need a qpidd for testing locally, but I suspect there
> are
> some dependency issues with the qpid-cpp package as /usr/sbin/qpidd
> is
> giving me unresolved symbols:
> 
>   /usr/sbin/qpidd: symbol lookup error: /usr/sbin/qpidd: undefined
> symbol:
> _ZN4qpid12create_valueISsEEPN5boost15program_options14value_semanticE
> RT_RKSs
> 
> This seems to be related to libboost_program_options.so that I have
> in
> 1.54.0.

Au contraire! This seems to have little to do with the version of
boost::program_options installed (afaict).

If you demangle the c++ symbol name you get (simplified for brevity):

boost::program_options::value_semantic*
qpid::create_value<std::string>(std::string&, std::string const&)

You can see from this that it is a symbol defined within qpid that is
missing - it merely returns a type from boost::program_options.

Having said that I didn't follow the rest of your conversation, but
whatever solved your problem wasn't what you think solved the problem!

If I had to, I'd guess that you had mismatched qpid libraries
installed.

Hope that dispels some voodoo.

Andrew


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message