qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Ivanov <iv...@logit-ag.de>
Subject Re: Autodelete queues not deleted
Date Thu, 05 Nov 2015 10:28:04 GMT
Is there a chance to get it working for 0.34 in foreseeable future? :-)

05.11.2015 13:27, Gordon Sim пишет:
> On 11/05/2015 10:14 AM, Michael Ivanov wrote:
>> Ok it worked! Probably last time when running recv I mistyped the queue name.
>> But weherever I run recv with such name queue is created and when the recv stopped
>> the queue was automatically deleted. But! It is also deleted when the send utility
>> terminated!
> 
> You are right, I'm sorry. For delete-on-close, the link that trigger the creation needs
to be registered as the controlling
> link. This is only done when using the dynamic flag in the source at present. So after
a single message, the queue gets deleted.
> 
> Sorry for taking up your time with an incomplete fix! It would take a slightly more involved
patch for the idea to work properly.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> For additional commands, e-mail: users-help@qpid.apache.org
> 


-- 
 \   / |			           |
 (OvO) |  Mikhail Iwanow                   |
 (^^^) |                                   |
  \^/  |      E-mail:  ivans@logit-ag.de   |
  ^ ^  |                                   |

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message