qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: Autodelete queues not deleted
Date Wed, 04 Nov 2015 19:51:54 GMT
On 11/04/2015 07:31 PM, Michael Ivanov wrote:
> Thanks for the fix suggestions!
>
> I have applied your patch to qpidd 0.34 and replaced libqpidbroker.so.2.0.0
> on test system. I restarted qpidd and verified that no error messages are
> generated for qpid-config add QueuePolicy command (there were errors with
> original version). Then I repeated my tests and the queues were still not
> deleted. Since the queues are created usin uuid, then I need to set queue
> policy for a queue pattern I guess? My reply queue names look like:
>
>     test2_tempSender4e978165-d3fa-4b25-b377-73aa1151b40e
>
> I tried to set queue policy for test2_tempSender, for test2_tempSender*
> and for test2_tempSender.* In all cases the queues werre not deleted.
>
> Am I doing sthing wrong or this is not possible with queue policy in 0.34?

No, that should work... just to verify, you are first subscribing to 
test2_tempSender4e978165-d3fa-4b25-b377-73aa1151b40e, then when the 
subscribing process ends the queue is not being deleted?

If you do `qpid-config queues` what do you see?


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message