qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ivan Judson <ivan.jud...@microsoft.com>
Subject windows 10 build - vs2015
Date Sat, 29 Aug 2015 15:46:31 GMT

Hi,

I'm continuing my investigation of building on w10 and vs15. I've followed the instructions
with cmake here:

https://git-wip-us.apache.org/repos/asf?p=qpid-proton.git;a=blob_plain;f=INSTALL.md;hb=0.10

and at this point:

Build and install from a command prompt (using msbuild)
    > cmake --build . --target install --config RelWithDebInfo

I get this error:

-- Installing: C:/Program Files (x86)/Proton/share/java/proton-j-0.10.jar
  CMake Error at proton-j/cmake_install.cmake:31 (file):
    file INSTALL cannot find
    "C:/dev/qpid-proton-0.10/build/proton-j/proton-j.jar".
  Call Stack (most recent call first):
    cmake_install.cmake:44 (include)

However, if I do the project files build specified next:


Loading the ALL_BUILD project into Visual Studio



  1. Run the Microsoft Visual Studio IDE

  2. From within the IDE, open the ALL_BUILD project file or proton

     solution file - it should be in the 'build' directory you created

     above.

  3. Select the appropriate configuration. RelWithDebInfo works best

     with the included CMake/CTest scripts


It builds just fine (but I'm guessing there's no installing into \Program Files (x86)).

Why is the cmake build trying to install the proton-j.jar when it wasn't built?

Thanks,

--Ivan

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message