qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marianne Rieckmann <marianne.rieckm...@adelaide.edu.au>
Subject Proton 0.9 and Qpid 0.32 using C++ broker on Windows, not connecting with protocol:ampq1.0
Date Fri, 17 Apr 2015 03:03:52 GMT
Hi,
I am new to Qpid, and have built and installed Proton 0.9 and Qpid 0.32 on Windows to try
out the C++ Broker, and the Qpid Messaging API. I would like to find an example that uses
the amqp 1.0 protocol.

The build environment is;
Windows 7 32bit
python 2.7.9
Ruby 1.9.3
cmake 2.8
for the qpid-cpp build I used the cmake -DOPENSSL_FOUND=FALSE -DNOBUILD_JAVA=TRUE options.

So the RUN_TESTS mostly worked.
The following tests FAILED:
  16 - federation_tests (Failed)
  17 - federation_sys_tests (Failed)
  19 - acl_tests (Failed)
  20 - cli_tests (Failed)
  21 - dynamic_log_level_test (Failed)
  22 - dynamic_log_hires_timestamp (Failed)
  23 - store_tests (Failed)
  24 - store_tests_clfs (Failed)
  25 - queue_redirect (Failed)

But examples worked out of the box when I started the Broker as follows
C:\>qpidd --no-data-dir --auth no
2015-04-17 11:03:46 [Broker] notice Broker (pid=3888) start-up
2015-04-17 11:03:46 [Broker] notice SASL disabled: No Authentication Performed
2015-04-17 11:03:46 [Security] error Failed to initialise SSL listener: Locating
 certificate VM1-PC in store My Cannot find object or property.  (.\qpid\broker\
windows\SslProtocolFactory.cpp:184)
2015-04-17 11:03:46 [Network] notice Listening on TCP/TCP6 port 5672
5672

Now executing the hello_world example (I have added the properties to the output);
C:\qpid\cpp\bin\Debug>hello_world "localhost:5672" "amq.topic" "{protocol:amqp0-10}"
Hello world!
Properties: {x-amqp-0-10.routing-key:}

C:\qpid\cpp\bin\Debug>hello_world "localhost:5672" "amq.topic" "{protocol:amqp1.0}"
Connect failed to amqp:tcp:localhost:5672: Reconnect disabled

So as we can see it works fine with amqp0-10 but failed to connect with amqp1.0

Can someone advise me on how to use Qpid with amqp1.0?
I am not sure
    1) if I have failed to install a required component, or
    2) if the failed tests are required to work, or
    3) if there is a bug that needs fixing in the message connection or broker.

Regards,
Marianne.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message