qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adams, Cory" <coad...@paypal.com.INVALID>
Subject Which java drivers to use
Date Thu, 14 Aug 2014 19:55:34 GMT
Hello,

There appear to be 3 different sets of java drivers.  What are the plans for each and how
do they differ?

There are:


1)      qpid-client, qpid-common (these work against activemq and qpid java broker - may work
against qpid c++ broker although the version needs to be specified when connecting otherwise
error on connecting results with unrecognized amqp version)

2)      qpid-amqp-1-0-client-jms, qpid-amqp-1-0-client, qpid-amqp-1-0-common (having trouble
attaching to the qpid c++ broker latest trunk version with "[Protocol] error Error on attach:
No target specified!")

3)      proton-j, proton-jms (docs only mention the qpid-client)

Also which of the above java libs in particular are recommended for the following?

ActiveMQ
Qpid Java broker
Qpid c++ broker

Thank you,

Cory

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message