qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Justin Ross <jr...@apache.org>
Subject Re: Packaging and virtual provides
Date Mon, 21 Jul 2014 19:36:18 GMT
For the client stuff, it's important to work in the name of the particular
API, as you suggest.

For the broker, I'd like to leave room for the possibility of packaging
other server types and servers implemented in other languages.  Our website
uses the following names for our servers:

  - C++ broker
  - Java broker
  - Dispatch router

So, to keep things conventional, I'd favor something along the lines of
qpid(cpp-broker), qpid(java-broker), qpid(dispatch-router).

We're still dealing with the confusion that has arisen from using "qpid" to
mean our project and a particular source module.  In an effort to avoid
this confusion, and reflect the true state of things at qpid, it's best to
think of the project as having these distinct source modules:

  - qpid-cpp
  - qpid-java
  - qpid-python
  - qpid-dispatch
  - qpid-jms
  - qpid-proton
  ...

I bring this up because it may be relevant to picking good names.

On Mon, Jul 21, 2014 at 2:34 PM, Darryl L. Pierce <dpierce@redhat.com>
wrote:

> Currently the upstream packages in Fedora provide the following virtual
> packages:
>
>  qpid-cpp-client       -> qpid(client)
>  qpid-cpp-client-devel -> qpid(client-devel)
>  qpid-cpp-client-rdma  -> qpid(client-rdma)
>  qpid-cpp-server       -> qpid(server)
>  qpid-cpp-server-ssl   -> qpid(server-ssl)
>  qpid-cpp-server-ha    -> qpid(server-ha)
>  qpid-cpp-server-rdma  -> qpid(server-rdma)
>  qpid-cpp-server-xml   -> qpid(server-xml)
>  qpid-cpp-server-store -> qpid(server-store)
>
> Justin pointed out that this doesn't provide enough detail and may cause
> problems in future if and when a new client API, for example, is
> provided.
>
> So, I'm looking for some ideas on better virtual package names to be
> provided. For example, the qpid-cpp-client API is qpid::messaging, so
> this virtual package could be better named:
>
>  qpid(messaging)
>
> In the same way the qpid-cpp-server virtual package would be:
>
>  qpid(broker)
>
> or:
>
>  qpid(qpidd)
>
> The other packages should have names that fall in line with those base
> names; i.e., messaging-devel or broker-ha.
>
> Ideas or thoughts?
>
> --
> Darryl L. Pierce, Sr. Software Engineer @ Red Hat, Inc.
> Delivering value year after year.
> Red Hat ranks #1 in value among software vendors.
> http://www.redhat.com/promo/vendor/
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message