qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Conway <acon...@redhat.com>
Subject Re: How can I configure dynamic route
Date Mon, 21 Jul 2014 15:58:50 GMT
On Tue, 2014-07-15 at 16:47 +0800, 郑勰 wrote:
> Hi,
> I have fixed this problem a few minutes ago,  I must start qpidd with
> --auth no,  although -auto no is default, it does seem not effect, if
> without —auth no,  type link list  showing that  B->C is not
> connected.

Actually the default is auth=yes, so that would explain the problem.


> 
> > 郑勰
> > 
> > 
> > 
> > 
> > 大数据产品部-商业智能中心-产品研发部
> > 
> > 
> > 亚信科技(中国)有限公司
> > 
> > 
> > 手机:186-1233-5012
> > 邮箱:zhengxie@asiainfo-linkage.com
> > 地址:北京市海淀区西北旺东路10号院东区亚信总部研发中心大厦

> > 邮编:100085
> > 
> > 
> 
> 
> 
> 在 2014年7月15日,下午4:37,Gordon Sim <gsim@redhat.com> 写道:
> 
> > On 07/15/2014 06:51 AM, zhengxie wrote:
> > > Hi,
> > > 
> > > I have some problems about qpid dynamic route. I am using quid
> > > 0.28 on
> > > linux 2.6.
> > > 
> > > The problem is like this:
> > > 
> > > I want to configure a dynamic route among host A,  B,  C like
> > > this :
> > > A<=>B<=>C,  I suppose message sent to A should be received in C,
> > >  however,
> > > the result is not,  I can only receive on B.  However,  if I open
> > > 3 ports on
> > > one host, each instance on each port,  the result is what I
> > > supposed to be.
> > > 
> > > This is how I configure on one host, my 3 hosts is 10.1.253.203,
> > > 10.1.253.230, 10.1.252.165. (below is abbreviate)
> > > 
> > > qpid-route dynamic add 203 230 amq.direct
> > > qpid-route dynamic add 230 203 amq.direct
> > > qpid-route dynamic add 230 165 amq.direct
> > > qpid-route dynamic add 165 230 amq.direct
> > > 
> > > This is how I test:
> > > 
> > > qpid-send -b 10.1.253.203 -a amq.direct/key230 --content-string
> > > "Hi,key230"
> > > --durable no
> > > 
> > > qpid-receive -b 10.1.252.165 -a amq.direct/key230 --timeout 200
> > > (no result)
> > > 
> > > Is there something wrong? I hunger for your answer. Thanks!
> > 
> > This is probably a stupid question, but just to confirm, you are
> > starting qpid-receive before qpid-send right? And allowing a little
> > time for the subscription to propagate?
> > 
> > There routes you set up above are as they should be.
> > 
> > Are there any errors in the broker logs (especially B and C? Can you
> > receive at C if you send to B (instead of A)?
> > 
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> > For additional commands, e-mail: users-help@qpid.apache.org
> > 
> 
> 





---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message