qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jakub Scholz <ja...@scholz.cz>
Subject All queues and exchanges displayed twice in qpid-tool
Date Sat, 26 Apr 2014 16:09:51 GMT
Hi,

I noticed that when I run my broker (0.28 RC1) with both QMF1 and QMF2
enabled, the qpid-tool shows all of the QMF objects twice. For example the
"list broker" command returns:
    ID   Created   Destroyed  Index
    =====================================================================
    129  16:03:39  -          amqp-broker
    130  16:03:39  -          org.apache.qpid.broker:broker:amqp-broker

the "list queue" returns:
    ID   Created   Destroyed  Index

=================================================================================
    149  16:03:44  -          173.qmfc-v2-hb-withe.14631.1
    150  16:03:44  -          173.qmfc-v2-ui-withe.14631.1
    151  16:03:44  -          173.qmfc-v2-withe.14631.1
    152  16:03:44  -          173.reply-withe.14631.1
    153  16:03:44  -          173.topic-withe.14631.1
    154  16:03:44  -
 org.apache.qpid.broker:queue:qmfc-v2-hb-withe.14631.1
    155  16:03:44  -
 org.apache.qpid.broker:queue:qmfc-v2-ui-withe.14631.1
    156  16:03:44  -
 org.apache.qpid.broker:queue:qmfc-v2-withe.14631.1
    157  16:03:44  -
 org.apache.qpid.broker:queue:reply-withe.14631.1
    158  16:03:44  -
 org.apache.qpid.broker:queue:topic-withe.14631.1

Are the QMF1 and QMF2 supposed to be mutually exclusive or is this a bug in
the qpid-tool?

Regards
Jakub

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message