qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: Qpid dependency of proton versions
Date Wed, 26 Mar 2014 15:14:24 GMT
On 03/26/2014 02:58 PM, Andrew Stitcher wrote:
> On Wed, 2014-03-26 at 11:39 +0000, Gordon Sim wrote:
>> ...
>> Using the CMAKE_PREFIX_PATH doesn't work for me either. Pointing it at
>> the latest 0.7rc3 installation gives:
>>
>>> CMake Warning at src/amqp.cmake:22 (find_package):
>>>    Could not find a configuration file for package "Proton" that is compatible
>>>    with requested version "0.5".
>>>
>>>    The following configuration files were considered but not accepted:
>>>
>>>      /home/gordon/qpid-releases/proton/0.7rc1/installation/lib64/proton.cmake/proton-config.cmake,
version: 0.7
>
> This is a leftover from a pre 0.7 build and is confusing the detection.

No, this was a completely clean installation of 0.7rc1 into a brand new 
directory. It didn't work with proton 0.6 either (identical error to the 
above, with just a different path and version). And the pkg-config 
approach doesn't work either.

> If you remove the install area completely and make install proton again
> it should work. I don't think the file proton-config.cmake made it into
> a proton release so there should only be a small number of people
> affected by this problem.
>
> Let me know if this didn't fix the problem and I will look at it some
> more.

I don't believe this is the issue. I did another completely clean 
install on a completely fresh OS install also.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message