qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: Qpid dependency of proton versions
Date Wed, 26 Mar 2014 11:39:36 GMT
On 03/26/2014 10:26 AM, Gordon Sim wrote:
> On 03/17/2014 06:49 PM, Andrew Stitcher wrote:
>> On Fri, 2014-03-14 at 10:02 +0000, Gordon Sim wrote:
>>> The _cmake_ build currently uses pkgconfig and I rely on that for
>>> testing against non-standard installs via PKG_CONFIG_PATH
>>
>> I've just changed this so that it uses the cmake config files instead.
>>
>>>
>>> That's not to say it can't change, as long as the same ability to simply
>>> build against a non-standard install remains there and the change when
>>> it happens is documented/publicised on this list.
>>
>> Ths pkg config methods are unchanged so there's nothing to report there.
>
> It doesn't appear to work for me any longer (tried using the 0.28 beta
> tarball and the latest trunk).
>
> I get:
>
>>> CMake Warning at src/amqp.cmake:22 (find_package):
>>>   By not providing "FindProton.cmake" in CMAKE_MODULE_PATH this
>>> project has
>>>   asked CMake to find a package configuration file provided by
>>> "Proton", but
>>>   CMake did not find one.
>>>
>>>   Could not find a package configuration file provided by "Proton"
>>> (requested
>>>   version 0.5) with any of the following names:
>>>
>>>     ProtonConfig.cmake
>>>     proton-config.cmake
>>>
>>>   Add the installation prefix of "Proton" to CMAKE_PREFIX_PATH or set
>>>   "Proton_DIR" to a directory containing one of the above files.  If
>>> "Proton"
>>>   provides a separate development package or SDK, be sure it has been
>>>   installed.
>>> Call Stack (most recent call first):
>>>   src/CMakeLists.txt:662 (include)

Using the CMAKE_PREFIX_PATH doesn't work for me either. Pointing it at 
the latest 0.7rc3 installation gives:

> CMake Warning at src/amqp.cmake:22 (find_package):
>   Could not find a configuration file for package "Proton" that is compatible
>   with requested version "0.5".
>
>   The following configuration files were considered but not accepted:
>
>     /home/gordon/qpid-releases/proton/0.7rc1/installation/lib64/proton.cmake/proton-config.cmake,
version: 0.7
>
> Call Stack (most recent call first):
>   src/CMakeLists.txt:662 (include)

A similar error (and note that the text is not that which appears to be 
coded into the cmake file itself) is given when trying to build against 
0.6 and against 0.5 I get the first error above since that release has 
no cmake files installed with it. Even using the 'recommended' approach 
of using the same installation prefix for proton and qpid-cpp doesn't work.

I'm using cmake 2.8.9 - I have also tried version 2.8.12.1 without 
success - and at present it seems I can't build qpid-cpp against proton 
at all. Has this been tested? If so, what am I doing wrong?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message