qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: Qpid dependency of proton versions
Date Thu, 13 Mar 2014 20:44:29 GMT
On 03/13/2014 07:39 PM, Andrew Stitcher wrote:
> Gordon
>
> Is there (still) a reason that qpid won't accept a version of proton
> newer than 0.6?

Only that I haven't tested it against anything newer.

I introduced the max-version check when the proton API changed. Since 
then I've kept the range to be that which I know will work.

> I'd like to change the check for proton to be simply (after my new work
> which should be going into Proton 0.7):
>
> find_package(Proton 0.5)

My only concern with an open ended dependency is around any future 
incompatible changes. If that is considered to be unlikely enough not to 
be a concern, then I don't object.

As to changing the cmake approach, I'm happy as long as it keeps working 
(both against non-standard locations, via pkg-config and on windows).

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message