qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fraser Adams <fraser.ad...@blueyonder.co.uk>
Subject Re: Qpid trunk r1568639 cpp build fails on ha_test_max_queues.cpp
Date Tue, 18 Feb 2014 19:20:21 GMT
Hi again Alan,
I've just tried this and it compiles fine this time - thanks, however 
I'm still seeing the (unrelated) issue that I reported a couple of weeks ago

qpidd --auth no
2014-02-18 19:07:16 [Store] notice Journal "TplStore": Created
2014-02-18 19:07:16 [Store] notice Store module initialized; 
store-dir=/home/fadams/.qpidd
2014-02-18 19:07:17 [Store] notice Linear Store: Journal "TplStore":Created
2014-02-18 19:07:17 [Store] notice Linear Store: EFP Manager 
initialization complete
2014-02-18 19:07:17 [Store] notice Linear Store: Store module 
initialized; store-dir=/home/fadams/.qpidd
2014-02-18 19:07:17 [Broker] error Multiple store plugins are not supported
2014-02-18 19:07:17 [Store] notice Journal "TplStore": Destroyed
2014-02-18 19:07:17 [Broker] critical Unexpected error: Failed to start 
broker: Multiple store plugins were loaded 
(/home/fadams/qpid/qpid-trunk/qpid/cpp/src/qpid/broker/Broker.cpp:424)
2014-02-18 19:07:17 [Store] notice Linear Store: Journal 
"TplStore":Destroyed


So basically both stores are installed by default, which means qpidd 
fails to start by default, which seems less than ideal.

It's easy to fix by deleting one of the store shared objects, but if 
0.28 release candidate is doing this I think it's a blocker. I raised 
https://issues.apache.org/jira/browse/QPID-5492 a month ago but there 
haven't been any comments on the Jira I didn't pursue it as I assumed 
that it might have been fixed but trying again when we're talking about 
a 0.28 release it seems worth flagging up again.

thoughts?

Frase




On 18/02/14 16:11, Alan Conway wrote:
> On Tue, 2014-02-18 at 11:04 -0500, Alan Conway wrote:
>> On Sat, 2014-02-15 at 16:55 +0000, Fraser Adams wrote:
>>> Hello all,
>>> I've just done an svn update to r1568639 and tried to build qpid cpp
>>>
>>> I did
>>> cmake -DCMAKE_BUILD_TYPE=Release ..
>>> and also, just to check
>>> cmake ..
>>>
>>> both fail for me using gcc 4.6.1
>>>
>>> I got as far as below - seems to be a problem with ha_test_max_queues.cpp
>>>
>>>
>>> Scanning dependencies of target ha_test_max_queues
>>> [ 80%] Building CXX object
>>> src/tests/CMakeFiles/ha_test_max_queues.dir/ha_test_max_queues.cpp.o
>>> /home/fadams/qpid/qpid-trunk/qpid/cpp/src/tests/ha_test_max_queues.cpp:32:5:
>>> error: unused parameter ‘argc’ [-Werror=unused-parameter]
>>> cc1plus: all warnings being treated as errors
>>>
>>> make[2]: ***
>>> [src/tests/CMakeFiles/ha_test_max_queues.dir/ha_test_max_queues.cpp.o]
>>> Error 1
>>> make[1]: *** [src/tests/CMakeFiles/ha_test_max_queues.dir/all] Error 2
>>> make: *** [all] Error 2
>> My bad! That would be a release build right? Stupid assert(). Fixing
>> now...
> Fixed.
> ------------------------------------------------------------------------
> r1569400 | aconway | 2014-02-18 11:09:23 -0500 (Tue, 18 Feb 2014) | 4
> lines
>
> NO-JIRA: Fix build error in ha_test_max_queues for release builds.
>
> argc was only being tested in an assert which was compiled out for
> release builds.
>
> ------------------------------------------------------------------------
>
> Of course "stupid assert" is short for "stupid developer who should know
> better than to use assert like that..."
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> For additional commands, e-mail: users-help@qpid.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message