qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Stitcher <astitc...@redhat.com>
Subject Re: Bindings for Google's Dart language.
Date Tue, 04 Feb 2014 16:50:29 GMT
On Tue, 2014-02-04 at 14:11 +0000, Steve Hamblett wrote:
> Can be found here <https://github.com/shamblett/amqp_client> for the
> interested

This looks very cool. It's always fun to see amqp supporting new
languages and projects. Is it in support of any specific project you'd
like to share?

The major comment I have is that it appears that you have built this API
on top of the old and now unsupported qpid::client API  - this will be a
problem from now on as we do not ship this as an external API any more
(from 0.26 our upcoming release).

The APIs to use is the qpid::messaging/qpid::types API. It looks that
you haven't done anything too dependent on the old API though so I don't
think this should be to hard to fix.

Are you interested in submitting it to the Qpid project? Obviously that
would be up to you. However if you want to, I believe you would need to
relicense the code to an Apache license.

Andrew



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message