qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fraser Adams <fraser.ad...@blueyonder.co.uk>
Subject Re: How to use lifetime policies
Date Thu, 16 Jan 2014 09:24:36 GMT
Hi Davin,
My *guess* (hope!!!) is that it's an environment/classpath thing

When I do an svn update of qpid trunk I generally do:
cd <qpid-root>/java
ant

Which builds the Qpid Java stuff (and look like your first step, though 
I just do "ant" not "ant -f build.xml build" - I doubt that makes any 
difference though)

I then do:
cd <qpid-root>/tools/src/java
ant cleanall
ant all

Again pretty similar to what you've done.

The error does seem indicative of a classpath issue, I think that I 
mentioned in the README that the Qpid client jars were needed on the 
classpath.

My .bashrc has the following stuff:

############################## HOME DIRECTORIES 
#############################

# Set up the location of the JDK
JAVA_HOME=/usr/lib/jvm/java-6-openjdk

# Clearly you'd need to set this to your own path
QPID_HOME=/home/fadams/qpid/qpid-trunk/qpid/java/build

#QPID_WORK is the working directory for the Java Broker - again you'd 
need to set this to your own path
QPID_WORK=/home/fadams/qpid-work

PATH=$JAVA_HOME/bin:$PATH:$QPID_HOME/bin

################################# CLASSPATH 
#################################

# Set up CLASSPATH
CLASSPATH=$CLASSPATH:$JAVA_HOME/lib/:$QPID_HOME/lib/qpid-all.jar:.


export JAVA_HOME QPID_HOME QPID_WORK PATH CLASSPATH

# End of .bashrc stuff



The qpid-all.jar is mostly just a manifest jar that pulls in everything, 
there's probably a better way to do this, but do date for me it's simple 
and convenient and how it's set on my dev environment.


The only thing that slightly troubles me is that from what I've gathered 
you've been running the Java Broker successfully, though it might be 
that the qpid-server startup script does some magic to work out the 
classpath for itself.

If your problem turns out *not* to be a classpath issue then I'm 
slightly stumped :-(

HTH,
Frase


On 15/01/14 22:22, Shearer, Davin wrote:
> Hi Frase,
>
> I'm very interested in the REST API for the C++ broker and I've got
> git-svn-id: https://svn.apache.org/repos/asf/qpid/trunk@155854913f79535-47bb-0310-9956-ffa450edef68
> checked out.  I went into the
> qpid/java directory and ran:
>
> ant -f build.xml build
>
> BUILD SUCCESSFUL
>
> Cool, so then I went into the tools/src/java directory and ran:
>
> ant all
>
> ...and I get a ton of errors all with 'error: package javax.jms does not
> exist'.  I'm obviously missing a pre-requisite.  I'm on Fedora19.  What am
> I missing?
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message