qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From uromahn <ulr...@ulrichromahn.net>
Subject Re: Serious Bug in AMQP 1.0 JMS Client with persistent messages
Date Wed, 08 Jan 2014 22:34:49 GMT
With the patch added to my local sources, I ran a bunch of different tests
against an ActiveMQ 5.9.0 and 5.10-SNAPSHOT broker using the patched as well
as unpatched client library.

To summarize my findings:
1. running the patched client against ActiveMQ 5.9.0 without sync-publish
set at all does not seem to force sync-publish which could be proven by
message loss when killing the broker
2. running the patched or unpatched client against ActiveMQ 5.9.0 with
sync-publish=true set explicitly is publishing one single message and then
"hanging" on the send() call
3. running the patched client against ActiveMQ 5.10-SNAPSHOT without
sync-publish set at all seems to force sync-publish as demonstrated by *no*
message loss when killing the broker
4. running the unpatched client against ActiveMQ 5.10-SNAPSHOT also seems to
force sync-publish as demonstrated by *no* message loss when killing the
broker.
5. running the patched or unpatched client against ActiveMQ 5.10-SNAPSHOT
with sync-publish=true explicitly set is publishing one single message and
then "hanging" on the send() call

In addition to the "hanging" of the send() call with sync-publish=true set,
I also sense an issue within ActiveMQ as well.




--
View this message in context: http://qpid.2158936.n2.nabble.com/Serious-Bug-in-AMQP-1-0-JMS-Client-with-persistent-messages-tp7602408p7602448.html
Sent from the Apache Qpid users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message