qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: ClassCastException when using amqp-1-0-jms-0.24 client
Date Wed, 11 Dec 2013 12:22:19 GMT
On 12/11/2013 12:19 AM, uromahn wrote:
> replying to self since original message was not posted to mailing list.
>
> uromahn wrote
>> All,
>>
>> maybe this is just me being stupid or it is really a bug and warrants a
>> ticket:
>>
>> Here it goes:
>> I have installed a qpid-cpp broker (via source) on my CentOS machine and
>> successfully started.
>> I have then created a simple (but more extended) test application using
>> the amqp-1-0-jms client library.
>> I can successfully connect to an ActiveMQ 5.9 as well as a qpid-java 0.24
>> broker and exchange messages via a configured queue.
>> However, when I connect to my qpid-cpp broker (also 0.24 with proton 0.4),
>> I can send messages to a queue, but when trying to read from the queue I
>> am getting the following error message:
>>
>> Exception in thread "Thread-7" java.lang.ClassCastException:
>> org.apache.qpid.amqp_1_0.type.Symbol cannot be cast to
>> org.apache.qpid.amqp_1_0.type.Section
>> 	at
>> org.apache.qpid.amqp_1_0.messaging.SectionDecoderImpl.parseAll(SectionDecoderImpl.java:49)
>> 	at org.apache.qpid.amqp_1_0.client.Receiver.receive(Receiver.java:280)
>> 	at
>> org.apache.qpid.amqp_1_0.jms.impl.MessageConsumerImpl.receive0(MessageConsumerImpl.java:286)
>> 	at
>> org.apache.qpid.amqp_1_0.jms.impl.SessionImpl$Dispatcher.run(SessionImpl.java:859)
>> 	at java.lang.Thread.run(Thread.java:744)
>> Please note: I also re-compiled my test app using the latest 0.26-SNAPSHOT
>> jms client from source with the exact same error - in fact, the stack
>> trace above comes from this version, in case anybody was wondering.

What type of message are you sending? i.e TextMessage, BytesMessage, 
MapMessage etc?

>> Also, to verify my installations are all correct, I tried a similar test
>> using the Java example coming with qpid-proton 0.5 and could successfully
>> connect and exchange messages with any broker speaking AMQP 1-0 (qpid-cpp,
>> qpid-java, ActiveMQ, and Apache Apollo)!
>> So, I must assume that my broker configuration, as simple as it may be,
>> should be correct.
>>
>> Any help or pointer what could be wrong would be very much appreciated,
>> -Uli


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message