qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fraser Adams <fraser.ad...@blueyonder.co.uk>
Subject [Client] error Tried to register protocol: tcp more than once?
Date Wed, 04 Dec 2013 20:11:24 GMT
Hi all,
a colleague of mine is seeing this message caused by some of his code:

"[Client] error Tried to register protocol: tcp more than once?"

TBH I've never seen that one before myself so I'm a bit stumped. I had a 
quick Google and came across
http://mail-archives.apache.org/mod_mbox/qpid-commits/200809.mbox/%3C20080911044528.83D51238896C@eris.apache.org%3E

So it looks like the message originates from some code that Andrew 
implemented a while back
"

Refactored c++ client library to allow multiple protocols to be
used simultaneously

"

I had a quick look through my colleague's code and I couldn't see 
anything "obviously" wrong with it although it was using the same 
session for sender and receiver, which seemed a bit unusual.

I don't suppose anyone has a suggestion as to the scenarios that might 
cause this error - certainly no obvious explicit "registering" of 
protocols seems to have taken place in his code.

Aside from the sender and receiver using the same session the only other 
thing popping though my mind is whether he has put the appropriate 
#ifndef protection in his *.h file, not doing that would probably mess 
with a static initialiser?

The code is using qpid::messaging on Qpid 0.18

any thoughts?

Cheers,
Frase



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message