qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Graham Leggett <minf...@sharp.fm>
Subject Re: Coaxing an error message out of qpid-cpp - unable to connect
Date Thu, 10 Oct 2013 16:30:00 GMT
On 10 Oct 2013, at 6:08 PM, Graham Leggett <minfrin@sharp.fm> wrote:

> javax.jms.JMSException: Failed to parse entry: Not an AMQP URL amqps://amqp.sandbox.xxx.net:5671?jms.prefetchPolicy.queuePrefetch=1
due to : Not an AMQP URL: amqps://amqp.sandbox.xxx.net:5671?jms.prefetchPolicy.queuePrefetch=1
> 
> The URL worked fine with qpid-java-amqp-1-0-client-jms, but suddenly doesn't work with
qpid-java-client - does the older JMS driver support SSL?

As an alternative I tried to modify the URL to be amqp://amqp.sandbox.xxx.net:5671?ssl=true&jms.prefetchPolicy.queuePrefetch=1,
and now I get the following equally mystifying error:

javax.jms.JMSException: Failed to parse entry: Virtual host found between indicies 7 and 25

amqp://amqp.sandbox.xxx.net:5671?ssl=true&jms.prefetchPolicy.queuePrefetch=1
       ^^^^^^^^^^^^^^^^^^^^^^^^^ due to : Virtual host found at index 7: amqp://amqp.sandbox.xxx.net:5671?ssl=true&jms.prefetchPolicy.queuePrefetch=1

Anyone know why the qpid-client JMS API should find virtual hosts offensive?

Regards,
Graham
--


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message