qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marko Asplund <marko.aspl...@gmail.com>
Subject Authenticating with AMQP Messenger API
Date Wed, 09 Oct 2013 20:35:03 GMT
Hi,

What's the correct way to authenticate to an AMQP server using the
Messenger API?
I've tried including authentication information in the AMQP address as
described in org.apache.qpid.proton.messenger.Messenger javadoc like this:

amqp://user1:pwd1@127.0.0.1:5672/topic://test.foo

This doesn't seem to work with ActiveMQ 5.8.0, though I'm able to
authenticate and communicate successfully using SwiftMQ client v9.4.0. With
Qpid the following entries appear in ActiveMQ log:

2013-10-09 23:31:21,863 | WARN  | Failed to add Connection
ID:vm-11457ca.ec.dmz-60686-1381348651307-2:13, reason:
java.lang.SecurityException: User name [null] or password is invalid. |
org.apache.activemq.broker.TransportConnection | ActiveMQ Transport:
tcp:///127.0.0.1:57217@5672
2013-10-09 23:31:21,863 | WARN  | Transport Connection to: tcp://
127.0.0.1:57217 failed: java.io.IOException: User name [null] or password
is invalid. | org.apache.activemq.broker.TransportConnection.Transport |
ActiveMQ Transport: tcp:///127.0.0.1:57217@5672
2013-10-09 23:31:26,933 | INFO  | Stopping tcp://127.0.0.1:57217 because
Failed with SecurityException: User name [null] or password is invalid. |
org.apache.activemq.broker.TransportConnection | ActiveMQ
BrokerService[localhost] Task-7

This happens with Proton 0.5.


marko

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message