qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Godfrey <rob.j.godf...@gmail.com>
Subject Re: Qpid AMQP 1.0 Integration with ActiveMQ
Date Wed, 02 Oct 2013 10:49:46 GMT
The qpid-client artefact is for implementations that speak AMQP
0-8,0-9,0-9-1 or 0-10.  To speak AMQP 1.0 (as ActiveMQ does) you should
only depend on the qpid-amqp-1-0-
client-jms artefact.

If you have included references to implementation classes in the
qpid-client  libraries you'll need to update your example to use the
equivalent implementations of JMS in qpid-amqp-1-0-client-jms.

-- Rob


On 2 October 2013 12:16, mrich <Matthew.Rich@qxlva.com> wrote:

> Hi,
>
> I am trying to integrate Qpid to ActiveMQ using AMQP 1.0 protocol. (e.g.
> create a Java client that is capable of reading and writing to an AMQP
> queue
> hosted by ActiveMQ (5.8), which uses version 1.0 of the protocol).
>
> I have created a project using the libraries on your website and your
> examples (e.g. 'Drain.java'), but when I run it I receive the following
> errors:
> Java Client/Project:  org.apache.qpid.AMQConnectionFailureException:
> connect() aborted [error code 200: reply success]
> ActiveMQ broker window: Caused by:
> org.apache.qpid.proton.engine.TransportException: AMQP header mismatch
> value
> 1, expecting 0
>
> I am using the following dependencies, as advised:
>
>         <dependency>
>             <groupId>org.apache.qpid</groupId>
>             <artifactId>qpid-client</artifactId>
>             <version>0.24</version>
>         </dependency>
>
>         <dependency>
>             <groupId>org.apache.qpid</groupId>
>             <artifactId>qpid-amqp-1-0-client-jms</artifactId>
>             <version>0.24</version>
>         </dependency>
>
>         <dependency>
>             <groupId>org.apache.geronimo.specs</groupId>
>             <artifactId>geronimo-jms_1.1_spec</artifactId>
>             <version>1.0</version>
>         </dependency>
>
> Looking through the code of the attached libraries, using AMQConnection as
> in the 'Drain' example, this doesnt appear to support AMQP 1.0 (looking at
> delegate).
>
> Could you please clarify if I am missing something, and any advice on how
> to
> get a Java client communicating with ActiveMQ on AMQP 1.0 is appreciated.
>
> Thanks.
>
>
>
> --
> View this message in context:
> http://qpid.2158936.n2.nabble.com/Qpid-AMQP-1-0-Integration-with-ActiveMQ-tp7598907.html
> Sent from the Apache Qpid users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> For additional commands, e-mail: users-help@qpid.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message