qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: Coaxing an error message out of qpid-cpp - unable to connect
Date Thu, 10 Oct 2013 16:36:33 GMT
On 10/10/2013 05:08 PM, Graham Leggett wrote:
> More investigation has shown that someone had hard coded the qpid ampq v1.0 driver directly
into the code, which was taking precedence. With that removed we're now getting further, but
still not out of the woods:
>
> javax.jms.JMSException: Failed to parse entry: Not an AMQP URL amqps://amqp.sandbox.xxx.net:5671?jms.prefetchPolicy.queuePrefetch=1
due to : Not an AMQP URL: amqps://amqp.sandbox.xxx.net:5671?jms.prefetchPolicy.queuePrefetch=1
>
> The URL worked fine with qpid-java-amqp-1-0-client-jms, but suddenly doesn't work with
qpid-java-client - does the older JMS driver support SSL?

Yes it does, but the configuration is entirely different between these 
two clients. In particular I don't believe the 0.8/0-9-1/0-10 client 
uses 'amqps' to indicate ssl is to be used:

http://qpid.apache.org/releases/qpid-0.24/programming/book/QpidJNDI.html

 From the examples in section  3.4 I think the "url" you would be 
looking for would be:

amqp://guest:guest@client_id/test?maxprefetch=1 
&brokerlist='tcp://amqp.sandbox.xxx.net:5671?ssl='true'sasl_mechs='EXTERNAL''

The client_id can be one of your own choosing of course and the username 
and password won't actually be chosen if you are using EXTERNAL 
authentication.

If you want to use a specific certificate you would use:

amqp://guest:guest@client_id/test?maxprefetch=1
	 
&brokerlist='tcp://amqp.sandbox.xxx.net:5671?ssl='true'&ssl_cert_alias='cert1'&sasl_mechs='EXTERNAL''


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message