qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From NimbusParc <nimbusp...@yahoo.in>
Subject Re: QPID AMQP Performance test
Date Tue, 01 Oct 2013 05:47:21 GMT
Which version of QPID you are using while testing ?
In the recent version of QPID-0.24, the --tcp-nodelay became Yes by default.
 If you are using previous versions, you need to pass this argument to get
better performance.
 

amitg90 wrote
> Hi All,
> 
> i am new to QPID, after downloading the software from website, i used the
> sample example code (recv.c and send.c) and modified on send side to
> continuouly send 64 bytes packets from machine A and on recevie side on
> machine B grabbing the packet and checking how much packets i received per
> sec and i am not able to see more than 18000 packets per sec (throughput
> 10Mbps).
> 
> being a 1Gbps link between two machines i was hoping for more throughput
> coming out of it.. 
> 
> i ran standard TCP performance test and it get close to 800Mbps
> throughput.
> 
> can someone please suggest if there is something obvious that i am missing
> or there exist some performance script which help me understand what is
> causing low throughput..
> 
> i can provide more details if that helps..
> 
> thanks
> amit





--
View this message in context: http://qpid.2158936.n2.nabble.com/QPID-AMQP-Performance-test-tp7598833p7598848.html
Sent from the Apache Qpid users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message