qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From CLIVE <cl...@ckjltd.co.uk>
Subject 0.22 Cmake build problem
Date Mon, 12 Aug 2013 21:30:56 GMT
Hi,

As the autotools build functionality is being deprecated, I tried to 
build the QPID 0.22 cpp source using the cmake build mechanism today, 
but had mixed results. I am building using RHEL5u4 64bit (cmake 2.6 
patched 4).

When using Autotools I use the --prefix option on /configure/ as the 
built version needs to reside in my companies ClearCase repository and 
installing in to the default area(s) is not an option.

Therefore I created a build directory, cd into it and then ran the 
following

*cmake -DCMAKE_INSTALL_PREFIX=/vobs/xxx_oss/qpid* ../

Cmake then went off and did its stuff and then I ran /make/ to build the 
source. The build worked fine and no errors were reported. Its the 
install step that then went wrong. After running /make install/  all the 
built cpp components were correctly installed in the directory defined 
by the CMAKE_INSTALL_PREFIX macro, but when it came to undertake the 
installation of some python components, they ignored the the 
CMAKE_INSTALL_PREFIX value and just tried to install the packages in the 
default python library directory, which failed as I do not have 
privileges to do this.

So the deprecation of the Autotools build would be a bit of a show 
stopper for me, as the Cmake installation is not able to replicate the 
autotools functionality.

I have undertaken a quick Google and this seems to be a known issue with 
the Python module(s) that come with Cmake.

Has anyone come across this, and if so have they managed to fix it?

Thanks in advance.

Clive


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message