qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Stitcher <astitc...@redhat.com>
Subject Re: [c++] Error while building qpid 0.20 from source distribution
Date Mon, 03 Jun 2013 15:38:17 GMT
On Tue, 2013-05-21 at 06:42 -0700, pela wrote:
> Christian Fromme wrote
> ...
> I'm on CentOS 5.5 and get the same error using configure/make or cmake. The
> error doesn't seem caused by missing pre-requisites though, more like a c++
> error. Actually I realize this is raised by gcc 3.4 but not gcc-4.4. Maybe
> support for gcc 3.4 has been dropped?
> 

Yes, I wouldn't expect the code to compile with gcc 3.4 anymore. If
you've got CentOS 5.5 I recommend you use the gcc 4.4 based compiler
rather than the compat compiler.

[It's not that we have explicitly dropped the compiler support, it's
more that that old compiler never fully supported C++99/03; and as we
developed, we stopped staying away from features that weren't
implemented in earlier versions of gcc. At least that's my
interpretation of events!]
Andrew



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message