qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject cmake issues for 0.22
Date Fri, 05 Apr 2013 13:41:34 GMT
There are two issue using cmake that I have been looking at.

(1) The issue brought up by Rob on the dev list regarding building with 
ssl on ubuntu (https://issues.apache.org/jira/browse/QPID-4702). I have 
a suggested patch for that waiting for some review.

(2) On gcc 4.1.2, e.g. as shipped on RHEL5, the messaging library as 
built by cmake does not throw the right type of exceptions 
(https://issues.apache.org/jira/browse/QPID-4701). I have committed a 
patch to trunk for that.

I'm noting these issues here to allow opinions to be expressed as to 
whether these should be blockers for 0.22 (where, as Alan mentioned 
earlier, cmake becomes the prefered build and autotools is usable but 
deprecated).

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message