qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fraser Adams <fraser.ad...@blueyonder.co.uk>
Subject Re: Ubuntu cmake woes - update 0.20 works, trunk still broken!!
Date Sat, 23 Mar 2013 17:43:46 GMT
On 23/03/13 16:57, Fraser Adams wrote:
> Hello again.
> one interesting thing I've just noticed is that if I manually do:
>
> sudo ldconfig
>
> then qpidd stops barfing with "qpidd: error while loading shared 
> libraries: libqpidbroker.so.2.0.0: cannot open shared object file: No 
> such file or directory" yay!!
>
Aha!!!!

So an update to the update :-)

In order to rule things out I cleaned everything up using the sudo xargs 
rm < install_manifest.txt thing then I took a *clean* qpid-0.20.tar.gz, 
unpacked it and did the cmake process in there.

now I still needed to manually do "sudo ldconfig" after I ran "sudo make 
install", but after that I did:
qpidd
2013-03-23 17:28:57 [Store] warning Message store plugin: No storage 
providers available.
2013-03-23 17:28:57 [Network] notice Listening on TCP/TCP6 port 5672
2013-03-23 17:28:57 [HA] notice Broker: Initializing: zappa:5672(joining)
2013-03-23 17:28:57 [Broker] notice Broker running

so, yippee!!!!!!!! - apart from the "sudo ldconfig" quirk that's a 
fairly clean cmake build of qpid 0.20 giving the same result I got with 
automake, result!!! :-)


So it looks like somebody has broken something on trunk :'( does anyone 
want to own up to doing something that causes
qpidd to barf with

2013-03-23 16:55:13 [Broker] critical Unexpected error: Error in 
configuration file /usr/local/etc/qpid/qpidd.conf: Bad argument: 
|cluster-mechanism=DIGEST-MD5 ANONYMOUS|

on trunk???

Ah well, some progress at least.
Frase




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message