qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fraser Adams <fraser.ad...@blueyonder.co.uk>
Subject Ubuntu cmake woes - update
Date Sat, 23 Mar 2013 17:00:23 GMT
Hello again.
one interesting thing I've just noticed is that if I manually do:

sudo ldconfig

then qpidd stops barfing with "qpidd: error while loading shared 
libraries: libqpidbroker.so.2.0.0: cannot open shared object file: No 
such file or directory" yay!!

However I still get:

qpidd
2013-03-23 16:55:13 [Broker] critical Unexpected error: Error in 
configuration file /usr/local/etc/qpid/qpidd.conf: Bad argument: 
|cluster-mechanism=DIGEST-MD5 ANONYMOUS|

Use --help to see valid options



Does anyone have any idea? I can clearly comment out that line in 
qpidd.conf, but qpidd.conf with "cluster-mechanism=DIGEST-MD5 ANONYMOUS" 
is the same as qpid 0.20 which worked fine (albeit using automake)


Rob, if you were getting things to run OK by doing ./qpidd in your 
bld/src directory you might want to try sudo ldconfig to see if you can 
get your installed qpidd to run OK. I take it you're not seeing the 
config file error? Are you building 0.21 off trunk?




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message