qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: Activating amqp 1.0 / proton in C++ messaging example
Date Tue, 05 Feb 2013 18:42:53 GMT
On 02/05/2013 01:36 AM, Paul O'Fallon wrote:
> Hello.  I wanted to follow up and mention that I tried this again by
> building qpid from the trunk (via cmake) and I still get the same error
> ("Unsupported protocol").  Is there something else I need to do beyond
> installing proton (which it says it found) and setting the load module
> environment variable?

There appears to be a further problem with the examples, I'm afraid. I 
haven't worked out exactly why. If you add a dummy connection variable 
at the start of main then the 1.0 support is registered correctly. (e.g. 
see attached patch).

The test programs also work, e.g. src/tests/qpid-send or 
src/tests/qpid-receive.

I'll dig around a bit more to find a proper fix. I suspect it must be 
some sort of static initialisation ordering issue.


Mime
View raw message