qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zhemzhitsky Sergey <Sergey_Zhemzhit...@sberbank-cib.ru>
Subject RE: We've got an App for that .... Qpid Web Based GUI - and more - just released.
Date Wed, 06 Feb 2013 07:17:01 GMT
Hello Frase,

>> If you've downloaded version 1.1

I've already tried. It works with Qpid 0.20. Thanks a lot.

>> Is it just msgDepth or do you see the same for msgTotalEnqueues msgTotalDequeues
too

msgDepth only (event with 1.1 version). All the other pages work pretty fine.


Best Regards,
Sergey 


-----Original Message-----
From: Fraser Adams [mailto:fraser.adams@blueyonder.co.uk] 
Sent: Monday, February 04, 2013 10:44 PM
To: users@qpid.apache.org
Subject: Re: We've got an App for that .... Qpid Web Based GUI - and more - just released.

On 04/02/13 12:34, Zhemzhitsky Sergey wrote:
>
> The only issues I've faced with are:
>
> 1. The GUI didn't work with qpid 0.20 client libs (as far as I 
> understand it’s already fixed)
If you've downloaded version 1.1 it should work with Qpid 0.20, the issue as you've probably
seen on the mailing list related to the way that amqp/list gets exposed to JMS clients. The
fix in qmf2-v1.1 used the fact that amqp/list is now exposed as a MapMessage, however after
the thread on that subject I was made aware that it's also possible to cast to a Qpid specific
ListMessage and get the java.util.list from that. That's much cleaner than messing around
with MapMessages so I'll move to that method on the next release.

There are also a bunch on new properties that are available for the queue object in Qpid 0.20
so I'll make sure that they get exposed in a sensible way too.

> 2. After going to queues->queue->msgDepth and clicking here and there 
> the GUI controls stops working until page refresh
>
>
Gosh that's one I've not come across, I can't think of a good reason off the top of my head.
Is it just msgDepth or do you see the same for msgTotalEnqueues msgTotalDequeues too? do you
get the same on the exchange or connection graphs?

The reason I ask is because they actually all navigate to the same graphs page and this gets
populated by the same JavaScript class so it's very *interesting* if you are only seeing it
on msgDepth and not the others.

Is this something that you are seeing often or is it a bit random/intermittent?

What browser are you using? That said I've tried it on loads :-(

My money is on something like trying to dereference a null object in JavaScript - when you
see this are you seeing any JavaScript errors? If you are would you be able to let me know
what it's saying. If you are on Chrome or Firefox it'd be *really* great if you'd be able
to run something like Web Console to see exactly where it's barfing.

I did *try* to put in a decent amount of defensive coding, but clearly there's no such thing
as too much defensive coding.

Anything to narrow it down gratefully received, I'm sure it's something really stupid :-D

Cheers,
Frase




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org For additional commands, e-mail:
users-help@qpid.apache.org


_______________________________________________________
CONFIDENTIALITY NOTICE: This email and any files attached to it may be confidential. If you
are not the intended recipient you are notified that using, copying, distributing or taking
any action in reliance on the contents of this information is strictly prohibited. If you
have received this email in error please notify the sender and delete this email. 

Mime
View raw message