qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Huston <shus...@riverace.com>
Subject RE: No such interface supported?
Date Tue, 12 Feb 2013 23:10:08 GMT
Yes, they should be compatible, and are except for some COM interfaces that changed. I thought
there was a JIRA open for this but I just looked and couldn't find it. I have some info on
this - I'll dig it out and open the JIRA - if you can develop a patch that would be great,
else funding some time for me to resolve it would also work.

-Steve

> -----Original Message-----
> From: Wurzinger Peter [mailto:Peter.Wurzinger@noel.gv.at]
> Sent: Tuesday, February 12, 2013 2:41 AM
> To: users@qpid.apache.org
> Subject: AW: No such interface supported?
> 
> Hi Steve!
> 
> I built Qpid on Windows 7 and deployed it on a Windows Server 2008, but in
> my opinion these two should be compatible. Is there another way to fix that?
> In the meantime I'll try to build Qpid on a Windows XP computer (in case I
> find one :-P).
> 
> Best Regards
> Peter
> 
> -----Urspr√ľngliche Nachricht-----
> Von: Steve Huston [mailto:shuston@riverace.com]
> Gesendet: Dienstag, 12. Februar 2013 00:20
> An: users@qpid.apache.org
> Betreff: RE: No such interface supported?
> 
> Did you build Qpid on an "up-rev" Windows (such as Vista or 7) and deploy on
> a "down-rev" version such as XP? The error you saw is common in that
> scenario. The easiest way around it is to build on XP; then you'd be able to
> run on any Windows version.
> 
> > -----Original Message-----
> > From: Wurzinger Peter [mailto:Peter.Wurzinger@noel.gv.at]
> > Sent: Monday, February 11, 2013 2:40 AM
> > To: users@qpid.apache.org
> > Subject: No such interface supported?
> >
> > Hi!
> >
> > After local testing I deployed Apache QPID 0.20 (x86) on one of our
> > server and I need to get it working with a MS-SQL - Database hosted on
> > the same server.
> > But when I start the Broker, I get the following error:
> > "error MSSQL can't open  at Provider=SQLOLEDB;Data Source=.;User
> > Id=username;Password=password: No such interface supported"
> > And right after that message I get:
> > "warning Message store plugin: No storage providers available."
> >
> > What could that be?
> > I run QPID with the following configuration file:
> >
> > data-dir=F:\TEST\qpid\data
> > auth=no
> > port=5672
> > max-connections=10000
> > trace=no
> > log-to-stderr=no
> > log-to-file=F:\TEST\qpid\logs\service.log
> > module-dir=F:\TEST\qpid\qpid-0.20\plugins\broker
> > connect=Data Source=servername;User
> > Id=test_qpidstore;Password=test_qpidstore_4u
> > catalog=test_QpidStore
> >
> > It's the same configuration file and the same binaries as I used for
> > local testing. I know, that the second message occours when there is a
> > problem loading the specified modules (store.dll and mssql_store.dll).
> > But as I said before, running the Broker locally works fine.
> >
> > I would appreciate if someone could help me with this problem :-)
> >
> > Best Regards
> > Peter
> >
> > PS: Please note, that the mentioned server is set up for testing
> > purposes only.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org For additional
> commands, e-mail: users-help@qpid.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org For additional
> commands, e-mail: users-help@qpid.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message