qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul O'Fallon" <p...@ofallonfamily.com>
Subject Re: Activating amqp 1.0 / proton in C++ messaging example
Date Thu, 17 Jan 2013 17:22:56 GMT
I only have one amqpc.so in my qpid installation, so I set QPID_LOAD_MODULE
to the full path of this file.  When specifying "protocol: amqp1.0" I get
the same error as before.  When leaving off the "protocol" connection
option, I do not get the "unsupported version" exception, but instead get
an "undefined symbol: pn_link_free" error.

- Paul


On Thu, Jan 17, 2013 at 5:41 AM, Gordon Sim <gsim@redhat.com> wrote:

> On 01/16/2013 05:58 PM, Paul O'Fallon wrote:
>
>> Ken, I tried setting that environment variable to point to my proton
>> library (/usr/lib/libqpid-proton.so) but still get the same errors (both
>> with and without specifying the protocol on the command line).
>>
>
> It is the amqpc.so library you want to load - i.e. the implementation of
> qpid::messaging that speaks 1.0 (and uses proton to do so) - not the proton
> library itself.
>
>
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.**org<users-unsubscribe@qpid.apache.org>
> For additional commands, e-mail: users-help@qpid.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message