qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul O'Fallon" <p...@ofallonfamily.com>
Subject Re: Activating amqp 1.0 / proton in C++ messaging example
Date Thu, 17 Jan 2013 22:34:06 GMT
If it helps, here's the debug log output for both scenarios (not supplying,
and then supplying, the protocol connection option):

~/qpid-0.20/cpp/examples/messaging$ ./client
myendpoint.servicebus.windows.net '{username: owner, password: mypass}'
2013-01-17 16:56:39 [Client] debug Created connection
myendpoint.servicebus.windows.net with {password:mypass, username:owner}
2013-01-17 16:56:39 [Client] debug Starting connection, urls=[
myendpoint.servicebus.windows.net]
2013-01-17 16:56:39 [Client] info Trying to connect to
myendpoint.servicebus.windows.net...
2013-01-17 16:56:39 [Client] debug Created IO thread: 0
2013-01-17 16:56:39 [Network] debug TCPConnector created for 0-10
2013-01-17 16:56:45 [System] info Connecting: x.x.x.x:5672
2013-01-17 16:56:45 [Network] debug RECV
[[y.y.y.y:57464-myendpoint.servicebus.windows.net:5672]]: INIT(1-0)
2013-01-17 16:56:45 [System] debug Exception constructed: Unsupported
version: 1-0 supported version 0-10
(~/qpid-0.20/cpp/src/qpid/client/TCPConnector.cpp:294)
2013-01-17 16:56:45 [System] error Caught exception in state: 3 with event:
1: Unsupported version: 1-0 supported version 0-10
(~/qpid-0.20/cpp/src/qpid/client/TCPConnector.cpp:294)
2013-01-17 16:56:45 [Client] warning Connection [y.y.y.y:
57464-myendpoint.servicebus.windows.net:5672] closed
2013-01-17 16:56:45 [System] debug Exception constructed: Connection
[x.x.x.x:57464-myendpoint.servicebus.windows.net:5672] closed
2013-01-17 16:56:45 [Client] info Failed to connect to
myendpoint.servicebus.windows.net: Connection [x.x.x.x:
57464-myendpoint.servicebus.windows.net:5672] closed
Failed to connect (reconnect disabled)

~/qpid-0.20/cpp/examples/messaging$ ./client
myendpoint.servicebus.windows.net '{username: owner, password: mypass,
protocol:amqp1.0}'
2013-01-17 16:56:51 [System] debug Exception constructed: Unsupported
protocol: amqp1.0
terminate called after throwing an instance of 'qpid::Exception'
  what():  Unsupported protocol: amqp1.0
Aborted (core dumped)

Thanks,
Paul



On Thu, Jan 17, 2013 at 4:47 PM, Paul O'Fallon <paul@ofallonfamily.com>wrote:

> I have proton installed in the standard / default location (/usr/lib).
>  I'm using proton 0.3 RC3 and qpid 0.2 RC4.
>
> Thanks,
> Paul
>
>
> On Thu, Jan 17, 2013 at 1:40 PM, Gordon Sim <gsim@redhat.com> wrote:
>
>> On 01/17/2013 05:22 PM, Paul O'Fallon wrote:
>>
>>> I only have one amqpc.so in my qpid installation, so I set
>>> QPID_LOAD_MODULE
>>> to the full path of this file.  When specifying "protocol: amqp1.0" I get
>>> the same error as before.  When leaving off the "protocol" connection
>>> option, I do not get the "unsupported version" exception, but instead get
>>> an "undefined symbol: pn_link_free" error.
>>>
>>
>> Is the proton library on your load path? If its not in the standard
>> install location then you'll need to set LD_LIBRARY_PATH. What version of
>> proton do you have?
>>
>>
>>
>> ------------------------------**------------------------------**---------
>> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.**org<users-unsubscribe@qpid.apache.org>
>> For additional commands, e-mail: users-help@qpid.apache.org
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message