qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From trivedi_ravi13 <trivedi_rav...@yahoo.co.in>
Subject Qpid 0.12 : Authentication failed when running a client with different linux user
Date Wed, 09 Jan 2013 18:46:12 GMT
Qpid 0.12 Broker and clients are running on different physical machines, i
have two users "root" & "ravi" on the machine where i am trying to run 
client application. When i run the client application from "ravi" user it
gives following error and does not connect to the broker.

"internal-error: Sasl error: SASL(-4): no mechanism available: No worthy 
mechs found (qpid/SaslFactory.cpp:280) "

However it works correctly when i run the same application from "root" user.
Broker uses PLAIN authentication mechanism. 

Even, I tried specifying the mechanism to be used as PLAIN from client side
using " ConnectionSettings" options in client API. But it did not work.

Is there any relation with user rights or file permissions on client side? 
 




--
View this message in context: http://qpid.2158936.n2.nabble.com/Qpid-0-12-Authentication-failed-when-running-a-client-with-different-linux-user-tp7586832.html
Sent from the Apache Qpid users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message