qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Huston <shus...@riverace.com>
Subject RE: Activating amqp 1.0 / proton in C++ messaging example
Date Tue, 15 Jan 2013 22:26:08 GMT
Hi Paul,

When you built Qpid 0.20-rc4 and started the broker  (I assume that's the broker you ran;
let me know if this is not true) did you load the proton module explicitly? Although the build
system found it and built it, my understanding is that it's built as a loadable module, not
built into the broker proper.

-Steve

> -----Original Message-----
> From: Paul O'Fallon [mailto:paul@ofallonfamily.com]
> Sent: Tuesday, January 15, 2013 5:14 PM
> To: users@qpid.apache.org
> Subject: Activating amqp 1.0 / proton in C++ messaging example
> 
> Hello.  I've had proton installed for a while, coding directly against it's C API
> (connecting to Azure ServiceBus).  Now I want to connect via c++ through
> Qpid itself.  I've built Qpid 0.20-rc4 and the build output indicates that it
> *does* find the proton libraries and that amqp 1.0 support is enabled.
> 
> When I run the "client" c++ example (in cpp/examples/messaging) without
> specifying a protocol option, I get "error Caught exception in state: 3 with
> event: 1: Unsupported version: 1-0 supported version 0-10" (i.e. it's trying
> amqp 0.10 and not 1.0).  However, when I add the connection option
> "protocol: amqp1.0" I get an error stating that this is an "Unsupported
> protocol".
> 
> Is there a different connection option I need to use to trigger the use of the
> proton library / amqp 1.0?
> 
> Thanks!
> 
> - Paul

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message