qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajesh Khan <rajeshkhan...@gmail.com>
Subject Re: Creating qpid broker service in windows
Date Tue, 04 Dec 2012 02:12:00 GMT
Figured it out Steve looks initially my PATH was pointing to a 32 bit boost
library and I was trying to run the 64 bit QPIDD broker that I built. After
changing the path of BOOST to 64-Bit I Got it up and running . Thanks for
the help.

On Mon, Dec 3, 2012 at 6:43 PM, Rajesh Khan <rajeshkhan808@gmail.com> wrote:

> Yes I can. It works when I start it from the command line. Here is the
> ouptut
>
> D:\qpid-0.18\qpid-0.18\cpp\src\Debug>qpidd
> 2012-12-03 18:41:36 [Security] error Failed to initialise SSL listener:
> Locating certificate FinFinancial-PC in store My Cannot find object or
> property.  (qpid\broker\windows\SslProtocolFactory.cpp:193)
> 2012-12-03 18:41:36 [Network] notice Listening on TCP/TCP6 port 5672
> 5672
> 2012-12-03 18:41:36 [Broker] notice Broker running
>
>
>
> On Mon, Dec 3, 2012 at 5:54 PM, Steve Huston <shuston@riverace.com> wrote:
>
>> I don't know why Rajesh, but it appears the service is starting and
>> stopping immediately after. State 1 in the message is SERVICE_STOPPED.
>>
>> Can you run qpidd from the command line, not as a service?
>>
>> -Steve
>>
>> On 12/3/12 7:30 PM, "Rajesh Khan" <rajeshkhan808@gmail.com> wrote:
>>
>> >Here is what I did
>> >added the following to my SYSTEM PATH
>> >D:\qpid-0.18\qpid-0.18\cpp\src\Debug\;D:\qpid-0.18\qpid-0.18\cpp;
>> >
>> >and then did the following
>> >D:\qpid-0.18\qpid-0.18\cpp\src\Debug>qpidd --install
>> >
>> >D:\qpid-0.18\qpid-0.18\cpp\src\Debug>qpidd --start
>> >2012-12-03 17:26:48 [Broker] critical Unexpected error: Service not yet
>> >running;
>> > state now 1 (windows\SCM.cpp:183)
>> >
>> >I am still getting the same message. I am surprised at why its not
>> working
>> >in my system and its working in yours. I also built the QPIDD CPP from
>> >scratch so I thought that everything was set up.
>> >
>> >D:\qpid-0.18\qpid-0.18\cpp\src\Debug>qpidd --install
>> >
>> >D:\qpid-0.18\qpid-0.18\cpp\src\Debug>qpidd --start
>> >2012-12-03 17:26:48 [Broker] critical Unexpected error: Service not yet
>> >running;
>> > state now 1 (windows\SCM.cpp:183)
>> >
>> >On Mon, Dec 3, 2012 at 5:21 PM, Steve Huston <shuston@riverace.com>
>> wrote:
>> >
>> >> Yes, I would set PATH to include the directory holding your qpid DLLs.
>> >>Be
>> >> sure it's the system-wide PATH and not your user PATH. No other env
>> >> variables are required for Qpid to run.
>> >>
>> >> -Steve
>> >>
>> >> On 12/3/12 6:49 PM, "Rajesh Khan" <rajeshkhan808@gmail.com> wrote:
>> >>
>> >> >Hi Steve could you tell me the Environment variables required by qpidd
>> >>?
>> >> >
>> >> >On Mon, Dec 3, 2012 at 4:42 PM, Rajesh Khan <rajeshkhan808@gmail.com>
>> >> >wrote:
>> >> >
>> >> >> Thanks for the email . I just checked my path environment and there
>> >>is
>> >> >>no
>> >> >> entry that points to qpid directory.
>> >> >> are you suggesting that I enter the path to my qpid (i.e)
>> >> >> D:\qpid-0.18\qpid-0.18\cpp\src\Debug in my PATH environment variable
>> >>?
>> >> >>
>> >> >>
>> >> >> On Mon, Dec 3, 2012 at 4:20 PM, Steve Huston <shuston@riverace.com>
>> >> >>wrote:
>> >> >>
>> >> >>> I just tried it and it worked fine.
>> >> >>>
>> >> >>> My only thought is that your DLLs are not in the PATH where
the
>> >>service
>> >> >>> process can find them. But that's a guess.
>> >> >>>
>> >> >>> -Steve
>> >> >>>
>> >> >>> On 12/3/12 4:22 PM, "Rajesh Khan" <rajeshkhan808@gmail.com>
wrote:
>> >> >>>
>> >> >>> >I have been working on this for a while and I still cant
figure
>> >>this
>> >> >>>out.
>> >> >>> >When I create a service it does not appear in the services.msc.
>> Has
>> >> >>> anyone
>> >> >>> >else successfully created a service using QPID
>> >> >>> >Here is what i am doing. I am not even trying to pass parameters
>> >> >>> >
>> >> >>> >D:\qpid-0.18\qpid-0.18\cpp\src\Debug>qpidd --install
>> >> >>> >D:\qpid-0.18\qpid-0.18\cpp\src\Debug>qpidd --start
>> >> >>> >2012-12-03 14:20:57 [Broker] critical Unexpected error:
Service
>> not
>> >> >>>yet
>> >> >>> >running;
>> >> >>> > state now 1 (windows\SCM.cpp:183)
>> >> >>> >D:\qpid-0.18\qpid-0.18\cpp\src\Debug>
>> >> >>> >
>> >> >>> >Any suggestions ?
>> >> >>> >
>> >> >>> >
>> >> >>> >
>> >> >>> >On Fri, Nov 30, 2012 at 3:51 PM, Steve Huston
>> >><shuston@riverace.com>
>> >> >>> >wrote:
>> >> >>> >
>> >> >>> >> Try starting the service from the Services component
of the
>> >>control
>> >> >>> >>panel
>> >> >>> >> instead of from the command line.
>> >> >>> >>
>> >> >>> >> > -----Original Message-----
>> >> >>> >> > From: Rajesh Khan [mailto:rajeshkhan808@gmail.com]
>> >> >>> >> > Sent: Friday, November 30, 2012 5:48 PM
>> >> >>> >> > To: users@qpid.apache.org
>> >> >>> >> > Subject: Re: Creating qpid broker service in
windows
>> >> >>> >> >
>> >> >>> >> > No logs in the Application and service logs by
qpidd
>> >> >>> >> >
>> >> >>> >> > On Fri, Nov 30, 2012 at 3:35 PM, Steve Huston
>> >> >>><shuston@riverace.com>
>> >> >>> >> > wrote:
>> >> >>> >> >
>> >> >>> >> > > he system event log?
>> >> >>> >>
>> >> >>> >>
>> >>
>> >>>---------------------------------------------------------------------
>> >> >>> >> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
>> >> >>> >> For additional commands, e-mail: users-help@qpid.apache.org
>> >> >>> >>
>> >> >>> >>
>> >> >>>
>> >> >>>
>> >> >>>
>> >>---------------------------------------------------------------------
>> >> >>> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
>> >> >>> For additional commands, e-mail: users-help@qpid.apache.org
>> >> >>>
>> >> >>>
>> >> >>
>> >>
>> >>
>> >> ---------------------------------------------------------------------
>> >> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
>> >> For additional commands, e-mail: users-help@qpid.apache.org
>> >>
>> >>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
>> For additional commands, e-mail: users-help@qpid.apache.org
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message