qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Terance Dias <tera...@socialtwist.com>
Subject Re: active-passive cluster
Date Tue, 16 Oct 2012 13:03:42 GMT
I tried giving the hostname --> IP address translation to /etc/hosts but it
did not work either. Then I tried giving the internal IP address of the
node where I was trying to run the cman service. The cman service did run
but it was not able to resolve the other node (which lies in another
network) with its static/external IP. Does cman only works with internal
IPs? Are all the nodes required to be in the same network for the cluster
to work?

Thanks,
Terance.

On Mon, Oct 15, 2012 at 9:14 PM, Pavel Moravec <pmoravec@redhat.com> wrote:

> That seems to be ok..
>
> Source code of cman seems to be not straightforward at that stage, maybe
> the cman preconfig does not fit with DNS..
>
> Let try to write the hostname -> IP address translation to /etc/hosts or
> ask in cman mailing list: http://sources.redhat.com/cluster/cman/
>
> Kind regards,
> Pavel
>
>
> ----- Original Message -----
> > From: "Terance Dias" <terance@socialtwist.com>
> > To: users@qpid.apache.org
> > Sent: Monday, October 15, 2012 8:31:53 AM
> > Subject: Re: active-passive cluster
> >
> > Thanks a lot for your reply Pavel.
> >
> > Below is my cluster.conf file.
> > -------------------------------------------
> > <?xml version="1.0"?>
> > <!--
> > This is an example of a cluster.conf file to run qpidd HA under
> > rgmanager.
> >
> > NOTE: fencing is not shown, you must configure fencing appropriately
> > for
> > your cluster.
> > -->
> >
> > <cluster name="test-qpid-cluster" config_version="18">
> >   <!-- The cluster has 2 nodes. Each has a unique nodid and one vote
> >        for quorum. -->
> >   <clusternodes>
> >     <clusternode name="ec2-node-1.amazonaws.com" nodeid="1"/>
> >     <clusternode name="ec2-node-2.amazonaws.com" nodeid="2"/>
> >   </clusternodes>
> >   <cman two_node="1" expected_votes="1">
> >   </cman>
> >   <!-- Resouce Manager configuration. -->
> >   <rm>
> >     <!--
> >         There is a failoverdomain for each node containing just that
> >         node.
> >         This lets us stipulate that the qpidd service should always
> >         run on
> > each node.
> >     -->
> >     <failoverdomains>
> >       <failoverdomain name="east-domain" restricted="1">
> >         <failoverdomainnode name="ec2-node-1.amazonaws.com"/>
> >       </failoverdomain>
> >       <failoverdomain name="west-domain" restricted="1">
> >         <failoverdomainnode name="ec2-node-2.amazonaws.com"/>
> >       </failoverdomain>
> >     </failoverdomains>
> >
> >     <resources>
> >       <!-- This script starts a qpidd broker acting as a backup. -->
> >       <script file="/usr/local/etc/init.d/qpidd" name="qpidd"/>
> >
> >       <!-- This script promotes the qpidd broker on this node to
> >       primary.
> > -->
> >       <script file="/usr/local/etc/init.d/qpidd-primary"
> > name="qpidd-primary"/>
> >     </resources>
> >
> >     <!-- There is a qpidd service on each node, it should be
> >     restarted if
> > it fails. -->
> >     <service name="east-qpidd-service" domain="east-domain"
> > recovery="restart">
> >       <script ref="qpidd"/>
> >     </service>
> >     <service name="west-qpidd-service" domain="west-domain"
> > recovery="restart">
> >       <script ref="qpidd"/>
> >     </service>
> >
> >     <!-- There should always be a single qpidd-primary service, it
> >     can run
> > on any node. -->
> >     <service name="qpidd-primary-service" autostart="1" exclusive="0"
> > recovery="relocate">
> >       <script ref="qpidd-primary"/>
> >     </service>
> >   </rm>
> > </cluster>
> > ----------------------------------------------
> >
> > The exact message I get when I start cman service is :
> >
> > ---------------------------------------------
> >
> > Starting cluster:
> >    Checking Network Manager... [  OK  ]
> >    Global setup... [  OK  ]
> >    Loading kernel modules... [  OK  ]
> >    Mounting configfs... [  OK  ]
> >    Starting cman... Cannot find node name in cluster.conf
> > Unable to get the configuration
> > Cannot find node name in cluster.conf
> > cman_tool: corosync daemon didn't start
> >
> > -------------------------------------------------
> >
> > Thanks,
> > Terance.
> >
> >
> > On Fri, Oct 12, 2012 at 7:38 PM, Pavel Moravec <pmoravec@redhat.com>
> > wrote:
> >
> > > Hi Terance,
> > > could you paste here your cluster.conf file?
> > >
> > > (I know I had the same issue some time ago, since I specify the
> > > hostname
> > > in /etc/hosts I dont have problems further - but that may be
> > > irrelevant).
> > >
> > > ----- Original Message -----
> > > > From: "Terance Dias" <terance@socialtwist.com>
> > > > To: users@qpid.apache.org
> > > > Sent: Friday, October 12, 2012 3:49:47 PM
> > > > Subject: active-passive cluster
> > > >
> > > > Hi,
> > > >
> > > > I'm using qpid trunk code and trying to set up the active-passive
> > > > cluster
> > > > mentioned at
> > > >
> > >
> http://qpid.apache.org/books/trunk/AMQP-Messaging-Broker-CPP-Book/html/chap-Messaging_User_Guide-Active_Passive_Cluster.html
> > > .
> > > > I'm having some trouble setting up cman and rpmanager 2 node
> > > > cluster
> > > > on
> > > > our Ubuntu-11.4 64 bit servers. Has anybody successfully set up
> > > > this
> > > > cluster on Ubuntu? It would be great if you could share some kind
> > > > of
> > > > resource or document that explains how this can be done. Right
> > > > now if
> > > > I
> > > > start cman I get an error saying "Starting cman... Cannot find
> > > > node
> > > > name in
> > > > cluster.conf" . The node names mentioned in my cluster.conf file
> > > > is
> > > > accessible through DNS lookup and I've opened the following ports
> > > > between
> > > > my servers.
> > > >
> > > > TCP - 41966,41967,41968,41969,50006,50008,50009,21064
> > > > UPD - 50007,5404,5405
> > > >
> > > > I'm not sure what I'm doing wrong.
> > > >
> > > > Thanks,
> > > > Terance.
> > > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> > > For additional commands, e-mail: users-help@qpid.apache.org
> > >
> > >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> For additional commands, e-mail: users-help@qpid.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message