qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ParkiratBagga <parkiratba...@gmail.com>
Subject Qpid Route with External IPs does not work correctly.
Date Mon, 01 Oct 2012 16:59:38 GMT
Hi,

I have setup 2 c++ qpid-servers(0.14 version) in different regions. 
Also I have setup a qpid-route between them with transport as SSL. 

qpid-route -d -s -t ssl queue add <destination-&lt;b>EXTERNAL-IP*:ssl-port>
<source-INTERNAL-IP:qpid-port> <exchange> <queue>

I am using external I.P to connect the destination to source, and the
destination is not reachable using the internal I.P.

The link is durable and the queues and exchanges are also durable in both
the servers.
Also, it is a push route from source to destination. 

Now, when I restart the source broker. The link survives and reconnects
back.
But, when I restart the destination broker, the link failover to the
internal I.P. of the destination broker.

Is this a bug, as I have given External I.P while creating the link but it
failovers to Internal I.P which is not reachable?

Is there any workaround for this?

Moreover, this is the problem with c++ broker(0.14).

I tested with c++ broker(0.18), where situation is more worse. 
Assuming the same setup as mentioned above. 
In version 0.18,

When I restart the source, it does not start, and in the logs it says trying
to establish the link but ssl is not supported transport type, and
When I restart the destination, behavior is the same as c++ version 0.14 as
mentioned above.

Regards,
Parkirat Singh Bagga.





--
View this message in context: http://qpid.2158936.n2.nabble.com/Qpid-Route-with-External-IPs-does-not-work-correctly-tp7582795.html
Sent from the Apache Qpid users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message