qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject Re: SSL between c++ brokers?
Date Wed, 12 Sep 2012 21:20:30 GMT
On 09/12/2012 09:19 PM, ParkiratBagga wrote:
> Thank You Gordon for the explanation.
>
> I tried the following command:
> qpid-route queue add <destination>:<non-ssl-port> <source>:<ssl-port>
> exchange queue
>
> It did not gave the Timeout this time. Also, it tried to create the route
> but the route which is being created is always in *Connecting State* and it
> is *not coming to Operational State*.
>
> Also, if route get created properly, then a consumer connection is
> established on the source queue, which is not coming.
>
> Below is the link status:
>
> *qpid-route link list
> Host                Port    Transport Durable  State             Last Error
> =========================================================
> <source host> 5674         ssl          Y     Connecting*
>
> Now what should I do further to resolve this?

Are there any errors in either broker's logs?

How have you setup the certificates for the two brokers? Do they each 
have their own cert? Is there a common CA or how is trust established?


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message