qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gordon Sim <g...@redhat.com>
Subject AMQP 1.0 (was Re: Java example Hello.java throws NPE)
Date Wed, 22 Aug 2012 09:37:25 GMT
On 08/21/2012 10:21 PM, Roger wrote:
> We are using rabbitmq which is using 0-9. Don't know if it will ever move to
> 0-10 - some differences of opinion on AMQP front.

Yes, the AMQP ride has had its share of bumps. However 1.0 is now out 
(and shortly to be approved as an OASIS standard), and I am hopeful that 
this will help achieve the vision AMQP set out with.

For example, the upcoming 0.18 release contains AMQP 1.0 support in the 
java broker and the JMS client (support from other components will 
hopefully be ready for the subsequent release).

Further, both the JMS client and the broker have been tested extensively 
against SwitfMQ which also supports AMQP 1.0. Full JMS compliance is now 
available regardless of which mix of components from these two products 
you use. This is a first for AMQP (and I believe for any wire protocol) 
and is I think a promising sign for the future.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message