qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ramith Jayasinghe <rami...@opensource.lk>
Subject Re: Build Qpid/C++ Broker on Windows 7 (64-Bit) with Visual Studio 2010.
Date Wed, 13 Jun 2012 12:47:38 GMT
HI Luca,
 Thanks for the reply. But setting ' set(Boost_ADDITIONAL_VERSIONS "1.49"
"1.49.0")' didn't work. My feeling is that cmake ( v 2.8.8) correctly
identifies the location of the boost and its version (since error message
throws out the correct path and the version). But somehow it fails without
finding the libraries? (does that even make sense ?)

Regards
Ramith.

On Wed, Jun 13, 2012 at 6:02 PM, Luca Martini <l.martini@list-group.com>wrote:

> Try to check if your CMake installation is able to recognize Boost version
> 1.49. Look at the file FindBoost.cmake in your cmake installation (mine is
> at
>
> C:\Program Files\CMake 2.8\share\cmake-2.8\Modules\**FindBoost.cmake
>
> )
>
> You can set the variable Boost_ADDITIONAL_VERSIONS (there is an example
> inside the file to include your boost version. For instance:
>
> set(Boost_ADDITIONAL_VERSIONS "1.49" "1.49.0")
>
> Hope it helps.
>        Luca
>
>
>
> On 13/06/2012 14:23, Ramith Jayasinghe wrote:
>
>> Hi People,
>>
>>  I'm trying to build Qpid (1.6) using visual studio 2010 and I'm stuck
>> with
>> following errors[4]. Steps I followed are based on
>> (<Qpid_Root>/cpp/INSTALL-**WINDOWS) but, I'm using versions higher than
>> what's described in the document (for example: boost : 1.49.0, Visual
>> Studio : 2010 Professional, Python : 2.7, Ruby : 1.93). Has anyone done
>> this before?
>> BTW, my ultimate goal is the build WCF binding  (<Qpid_Root>/wcf).
>>
>> Steps I followed are:
>>
>> (i) Install cmake, python, ruby,
>> (ii) Install boost ( path : is C:/Program Files/boost/boost_1_49_0 )
>> (iii) build boost ( C:/Program Files/boost/boost_1_49_0/**stage/lib
>> contains
>> the  output libraries)
>> (iii) set environment variables as following:
>>
>> BOOST_ROOT= C:\Program Files\boost\boost_1_49_0
>> BOOST_LIBRARYDIR = C:\Program Files\boost\boost_1_49_0\**stage\lib
>> BOOST_INCLUDEDIR = C:\Program Files\boost\boost_1_49_0
>>
>> (iv) From the command prompt invoke cmake ( cmake -i -G "Visual Studio
>> 2010" )
>>
>>
>> Errors:
>>
>> CMake Error at C:/Program Files (x86)/CMake
>> 2.8/share/cmake-2.8/Modules/**FindBoost.cmake:1200 (message):
>>   Unable to find the requested Boost libraries.
>>
>>   Boost version: 1.49.0
>>
>>   Boost include path: C:/Program Files/boost/boost_1_49_0
>>
>>   The following Boost libraries could not be found:
>>
>>           boost_filesystem
>>           boost_program_options
>>           boost_date_time
>>           boost_thread
>>           boost_unit_test_framework
>>           boost_regex
>>
>>   No Boost libraries were found.  You may need to set BOOST_LIBRARYDIR to
>> the
>>   directory containing Boost libraries or BOOST_ROOT to the location of
>>   Boost.
>> Call Stack (most recent call first):
>>   src/CMakeLists.txt:310 (find_package)
>>
>>
>
> --
> Luca Martini
> List S.p.A.
> Via Pietrasantina 123, 56122 Pisa, ITALY
> +39 050 8001696 (Direct)
> +39 050 800151  (Switch)
> +39 050 8001701 (Fax)
> e-mail: l.martini@list-group.com  web: http://www.list-group.com
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message