qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cliff Jansen <cliffjan...@gmail.com>
Subject Re: Problem with building the C# Wcf Channel
Date Tue, 22 May 2012 14:09:08 GMT
Hi Robert,

I regularly build the WCF channel using VS2008, but haven't from trunk
since 0.16.  CMake doesn't understand C# and C++/CLI, so the
projects/solutions aren't particularly flexible.  Be sure to choose
the correct Debug/Release + Win32/x64 options to match your CMake
choices.

 - What version of Qpid are you trying to build?
 - What version of boost are you using? (Self compiled?)
 - What version of CMake?
 - Debug/Release?
 - 32/64 bit?

Cliff

On Tue, May 22, 2012 at 3:51 AM, Robert Evans <zwergzebra@googlemail.com> wrote:
> Hello,
>
> I want to build the Wcf Channel files using VS 2008 and the QpidWcf
> solution, but I am getting a linker error when linking the InputLink.obj of
> the Interop project.
> it is error LNK2001: Unresolved external symbol.
>
> Here is the complete error description:
> Fehler 8 error LNK2001: Unresolved external symbol ""public: class
> std::_Tree<class std::_Tmap_traits<class std::basic_string<char,struct
> std::char_traits<char>,class std::allocator<char> >,class
> boost::shared_ptr<class qpid::framing::FieldValue>,struct std::less<class
> std::basic_string<char,struct std::char_traits<char>,class
> std::allocator<char> > >,class std::allocator<struct std::pair<class
> std::basic_string<char,struct std::char_traits<char>,class
> std::allocator<char> > const ,class boost::shared_ptr<class
> qpid::framing::FieldValue> > >,0> >::const_iterator __thiscall
> qpid::framing::FieldTable::end(void)const " (?end@FieldTable@framing@qpid
> @@$$FQBE?AVconst_iterator@?$_Tree@V?$_Tmap_traits@V?$basic_string@DU
> ?$char_traits@D@std@@V?$allocator@D@2@@std@@V?$shared_ptr@VFieldValue
> @framing@qpid@@@boost@@U?$less@V?$basic_string@DU?$char_traits@D@std@
> @V?$allocator@D@2@@std@@@2@V?$allocator@U?$pair@$$CBV?$basic_string@DU
> ?$char_traits@D@std@@V?$allocator@D@2@@std@@V?$shared_ptr@VFieldValue
> @framing@qpid@@@boost@@@std@@@2@$0A@@std@@@std@@XZ)". InputLink.obj Interop
>
> I don't know what the problem could be, as compiling der Interop project
> works and I also built the C++ broker (works) and all libraries
> mentioned in the Installation ReadMe of the Wcf Channel. Does anyone have
> an idea or could send me the built solution?
>
> Thanks for your help!
>
> Robert

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message