qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Godfrey <rob.j.godf...@gmail.com>
Subject Re: Is it possible to run qpid-0.14 c++ broker with lower 0-9 amqp specification?
Date Thu, 26 Apr 2012 08:26:47 GMT
The documentation is a little out of date.

The C++ Broker only support version 0-10 of the protocol, with support
for AMQP 1.0 coming soon.

The Java Broker supports versions 0-8, 0-9, 0-9-1 and 0-10 with
support for AMQP 1.0 coming soon (you can check out the latest code
from svn to get initial AMQP 1.0 support).

Why do you need to use AMQP 0-9?

Cheers,
Rob

On 26 April 2012 10:21, Zhihua Che <zhihua.che@gmail.com> wrote:
> Hi,
>
>     I've installed a qpid-0.14 C++ broker and it works well? I wonder
> if it's ok to run this broker with 0-9 amqp specifications?
>     I found this statement in doc
>
> The python and ruby clients will also support all versions, but the
> API is dynamically driven by the specification used and so differs
> between versions. To work with the Java broker you must use 0-8 or
> 0-9, to work with the C++ broker you must use 0-10.
>
>    Does it mean I have to install java broker instead to use amqp 0-9?
>
> Thanks
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
> For additional commands, e-mail: users-help@qpid.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message