qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pervez, Salman" <Salman.Per...@citadelgroup.com>
Subject boost error
Date Tue, 13 Mar 2012 23:12:58 GMT
Hi everyone, I am trying to do a source build for qpid 0.14. I am running into a boost dependency
error which I am unable to solve. Perhaps I should be posting this on a boost users list but
I was hoping if someone encountered something similar they might be able to help me out. Here
is the error...

/usr/bin/ld: cannot find -lboost_program_options
collect2: ld returned 1 exit status
make[2]: *** [libqpidcommon.la] Error 1

I also built boost from source so its no surprise that it cannot find the required file in
/usr/bin/ld. Perhaps there is a way to tell it where to find boost? I passed the location
of my boost build to the configure script through a CPPFLAG which helps it find the hpp files
but perhaps not this one. I'll appreciate any input on this. Thanks!

Salman

________________________________

CONFIDENTIALITY AND SECURITY NOTICE

The contents of this message and any attachments may be confidential and proprietary and also
may be covered by the Electronic Communications Privacy Act. This message is not intended
to be used by, and should not be relied upon in any way, by any third party. If you are not
an intended recipient, please inform the sender of the transmission error and delete this
message immediately without reading, disseminating, distributing or copying the contents.
Citadel makes no assurances that this e-mail and any attachments are free of viruses and other
harmful code.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message