qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Huston" <shus...@riverace.com>
Subject RE: boost error
Date Thu, 15 Mar 2012 11:37:40 GMT
Did you see the -L/tp64/boost/1.44.0 option passed to the command that
failed?

Is libboost_program_options.so (and the other Boost libs) in
/tp64/boost/1.44.0? Or in a subdirectory of that? I'm guessing a
subdirectory - you would need to specify the complete path to the
directory where the libs are located with -L.

-Steve


> -----Original Message-----
> From: Pervez, Salman [mailto:Salman.Pervez@citadelgroup.com]
> Sent: Wednesday, March 14, 2012 6:41 PM
> To: users@qpid.apache.org
> Subject: RE: boost error
> 
> Steve, thanks for the help. Unfortunately this does not seem to work.
> 
> CXXFLAGS=-I/tp64/boost/1.44.0 LDFLAGS=-L/tp64/boost/1.44.0 ./configure -
> -prefix=/home/spervez1/qpid-\ Tools
> CXXFLAGS=-I/tp64/boost/1.44.0 LDFLAGS=-L/tp64/boost/1.44.0 make install
> 
> Still gives me the same error message.
> 
> /usr/bin/ld: cannot find -lboost_program_options
> collect2: ld returned 1 exit status
> 
> I read online that boost now requires explicit declaration of st or mt
> semantics so I replaced occurrences of lboost_program_options with
> lboost_program_options-mt but that does not work. I also tried giving
> configure the argument --with-boost=<...> but it did not recognize that
> option. Any other thoughts?
> 
> Salman
> 
> -----Original Message-----
> From: Steve Huston [mailto:shuston@riverace.com]
> Sent: Wednesday, March 14, 2012 12:39 PM
> To: users@qpid.apache.org
> Subject: RE: boost error
> 
> Hi Salman,
> 
> You came to the right place.
> 
> Since you passed CPPFLAGS to the build, which helps the compiler find
the
> headers, you should also try passing LDFLAGS=-L<path to the boost libs>
> 
> -Steve
> 
> > -----Original Message-----
> > From: Pervez, Salman [mailto:Salman.Pervez@citadelgroup.com]
> > Sent: Tuesday, March 13, 2012 7:13 PM
> > To: users@qpid.apache.org
> > Subject: boost error
> >
> > Hi everyone, I am trying to do a source build for qpid 0.14. I am
> running into a
> > boost dependency error which I am unable to solve. Perhaps I should be
> > posting this on a boost users list but I was hoping if someone
> encountered
> > something similar they might be able to help me out. Here is the
> error...
> >
> > /usr/bin/ld: cannot find -lboost_program_options
> > collect2: ld returned 1 exit status
> > make[2]: *** [libqpidcommon.la] Error 1
> >
> > I also built boost from source so its no surprise that it cannot find
> the
> > required file in /usr/bin/ld. Perhaps there is a way to tell it where
> > to
> find
> > boost? I passed the location of my boost build to the configure script
> through
> > a CPPFLAG which helps it find the hpp files but perhaps not this one.
> I'll
> > appreciate any input on this. Thanks!
> >
> > Salman
> >
> > ________________________________
> >
> > CONFIDENTIALITY AND SECURITY NOTICE
> >
> > The contents of this message and any attachments may be confidential
> > and proprietary and also may be covered by the Electronic
> > Communications Privacy Act. This message is not intended to be used
> > by, and should not
> be
> > relied upon in any way, by any third party. If you are not an intended
> > recipient, please inform the sender of the transmission error and
> > delete
> this
> > message immediately without reading, disseminating, distributing or
> copying
> > the contents. Citadel makes no assurances that this e-mail and any
> > attachments are free of viruses and other harmful code.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org For additional
> commands, e-mail: users-help@qpid.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org For additional
> commands, e-mail: users-help@qpid.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@qpid.apache.org
For additional commands, e-mail: users-help@qpid.apache.org


Mime
View raw message