qpid-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robbie Gemmell <robbie.gemm...@gmail.com>
Subject Re: problems using cqpid with java broker
Date Mon, 13 Feb 2012 22:20:58 GMT
Thanks to Gordon for stepping in here and helping out with the C++
client/python bindings side of things, I had admittedly missed that
point and wouldn't have had much of a clue on that front :)

On the below, it would appear that the commands you are using are
resulting in the client trying to declare an existing exchange (e.g.
amq.topic) with a different exchange type than it exists with already
(i.e not topic). I'm rather entrenched in JMS land and dont have that
good an idea of the Address Strings, but I guess I would maybe be
taking a look at the arguments you are feeding to Spout in that case.

I have updated the message of the session execution exception the Java
broker emits when this occurs to list the exchange name and the two
conflicting exchange types in question. I forced an early build of the
nightly trunk Java release job, so you should now be able to get the
updated broker artifact here if you dont want to build your own:
https://builds.apache.org/view/M-R/view/Qpid/job/Qpid-Java-Artefact-Release/lastSuccessfulBuild/artifact/trunk/qpid/java/broker/release/

Regards,
Robbie

On 13 February 2012 19:29, Brandon Pedersen <bpedman@gmail.com> wrote:
> On Mon, Feb 13, 2012 at 11:35 AM, Gordon Sim <gsim@redhat.com> wrote:
>> try username/password@localhost as the broker
>
> whoops, yeah, forgot the syntax of the spout command :) it is working
> now...except I still have one problem, I cannot create a sender to a
> topic exchange...the spout program works fine for a direct
> queue/exchange, but when I try to use a topic exchange it tells me
> "not-allowed: Cannot redeclare with a different exchange type" (and I
> get this same error message now from my python cqpid code).
>
> Here is the command and output I am getting with spout:
> $ ./spout -b admin/admin@localhost -c 1 amq.topic/test
> 2012-02-13 12:25:24 warning Exception received from broker:
> not-allowed: Cannot redeclare with a different exchange type [caused
> by 2 \x00:\x00]
> not-allowed: Cannot redeclare with a different exchange type
>
> And my python cqpid stuff is just opening the connection and a session
> and then doing 'sender = session.sender("test.topic")' and gets the
> same error.
>
> Thanks for your help,
>
> -Brandon
>
> ---------------------------------------------------------------------
> Apache Qpid - AMQP Messaging Implementation
> Project:      http://qpid.apache.org
> Use/Interact: mailto:users-subscribe@qpid.apache.org
>

---------------------------------------------------------------------
Apache Qpid - AMQP Messaging Implementation
Project:      http://qpid.apache.org
Use/Interact: mailto:users-subscribe@qpid.apache.org


Mime
View raw message